Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

Not applicable
We have been using XMC1300 J-Link Lite Bootkit to Get/Set BMI, Program and Debug XMC1302. We have ordered four new XMC1300 J-Link Lite Bootkits last month. With our old bootkit (the same model but previously ordered than these four), we were able to do all these three operations. But I am afraid to let you know that we are not able to Get/Set BMI from these new Kits though we are able to program and debug. The error states that we have to update the driver, we also did that. Now the driver is up-to-date. FYI, this problem lies in both DAVE 3.1.8 and DAVE 4.1.2.We are quite an old customer of Segger and Infineon, so I kindly request you to help us resolve this issue as soon as possible.

Thanks in advance.

Shaunak Agastya Vyas
0 Likes
7 Replies
jferreira
Employee
Employee
First like received 750 replies posted 500 replies posted
Hi,

Which version of Segger JLink are you using?
Could you try with XMC Flasher tool?

Regards,
Jesus
0 Likes
Not applicable
We are using CPU-13A-V1.

Shaunak Agastya Vyas
0 Likes
Not applicable
The link given to XMC Flasher gives following error:

An error occurred while processing your request.
Reference #97.ad453917.1493957715.1f759fe3

Shaunak Agastya Vyas
0 Likes
jferreira
Employee
Employee
First like received 750 replies posted 500 replies posted
Hi,

For me it works. Could you try again?
I was referreing to the JLink version not to the board version.
The current JLink version is v6.14f.
You can also use the JLink commander. In the Start Windows menu, in the SEGGER/J-Link folder click in JLink Commander.
2649.attach

Regards,
Jesus
0 Likes
Not applicable
@Jesus: I went to try on JLink Commander. It was able to recognize my device, but It stated that the firmware of JLink is too old.2650.attach
0 Likes
Not applicable
@Jesus: I went to try on JLink Commander. It was able to recognize my device, but It stated that the firmware of JLink is too old.2650.attach

Shaunak Agastya Vyas
0 Likes
Not applicable
@Jesus: I went to try on JLink Commander. It was able to recognize my device, but It stated that the firmware of JLink is too old.2650.attach

Shaunak
0 Likes