Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
bluefish97
Level 2
Level 2
10 sign-ins 5 questions asked 5 replies posted

Hi,

i would like to connect an external nor flash memory from ISSI to the XMC7100 EVK board (preferably through qspi or through spi). How can i do this? which gpio pins are available and how can I configure this in through the Eclipse IDE for ModusToolbox.

I would ultimately want to connect the serial flash write/read application.

Best regards,

PrasadA

0 Likes
1 Solution
Maragani
Moderator
Moderator
Moderator
25 solutions authored 10 likes received 100 replies posted

Hi @bluefish97 

Based on our discussion, i am closing this case. We will continue our discussion in the below thread.
https://community.infineon.com/t5/XMC/Mtb-littlefs-in-XMC7100-external-flash/td-p/743057
Thanks
Sateesh  M

View solution in original post

0 Likes
3 Replies
Maragani
Moderator
Moderator
Moderator
25 solutions authored 10 likes received 100 replies posted

Hi @bluefish97 

You can use Device configurator from MTB, and QSPI configurator from project creator tool, please check the below weblink for QSPI configurator.

Device COnfigurator:

https://www.infineon.com/dgdl/Infineon-ModusToolbox_Device_Configurator_4.0_User_Guide-UserManual-v0...

QSPI COnfigurator:

https://www.infineon.com/dgdl/Infineon-ModusToolbox_QSPI_Configurator_4.0_User_Guide-UserManual-v01_...

Kindly check and please let us know any further support is required.

Thanks 
Sateesh M

Hi,

There is no QSPI port available in the XMC7100D as the P7 port (port visible in device configurator4.2 for QSPI pheripheral)  is attached to inbuild nor flash memory. Therefore not accessible to users and if selected wouldnt it call the inbuild flash and threow errors (due to changing QSPI Configuration in my progrtam to my flash memory).

For SPI Communication I am not able to use the function call "cy_serial_flash_qspi_init(bd_cfg->mem_config,bd_cfg->io0, bd_cfg->io1, bd_cfg->io2, bd_cfg->io3,bd_cfg->io4, bd_cfg->io5, bd_cfg->io6, bd_cfg->io7,bd_cfg->sclk, bd_cfg->ssel, bd_cfg->freq_hz);" 

(I connected my spi nor flashs memory to SCB P13[0-3])

 

PS. My IS25LP128 flash memory does have single SPI, Dual SPI, Quad SPI.


Best,

PrasadA

0 Likes
Maragani
Moderator
Moderator
Moderator
25 solutions authored 10 likes received 100 replies posted

Hi @bluefish97 

Based on our discussion, i am closing this case. We will continue our discussion in the below thread.
https://community.infineon.com/t5/XMC/Mtb-littlefs-in-XMC7100-external-flash/td-p/743057
Thanks
Sateesh  M

0 Likes