Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Not applicable
Hello,


actually we work on a Datalogger with the XMC4500 which uses CAN NODE APP and the FAT FS APP. The project was built on the first version of Dave4. In this older version the FAT FS APP was not supported. So we Upgrade the project to V4.2.6.
There we get sometimes a strange error, when we click to "Generate Code" and after to "Build Active Project". I took a Screenshot of this behaviour.
Thank you for any answer!!!
0 Likes
5 Replies
DRubeša
Employee
Employee
First solution authored First like received
HI Knecht Patrick,

I´ve tried to reconstruct the issue that you experience, but I miss a lot of additional information. I added CAN_NODE APP and FAT_FS APP with both SD and SPI mode and I cannot replicate your error. I´m using DAVE v4.2.8, but I´m not sure that´s the relevant to the issue you experience. It would be easiest if you can submit your project files (if it´s a confidential, then at least send me APP Dependency Diagram so I can try to match my guinea pig project to yours as much as possible).

Best regards,
Deni
0 Likes
lock attach
Attachments are accessible only for community members.
Not applicable
Hello DRubesa,

I tried to add the whole project. Actually this project gives me the error, what I described in the preview post.
Thanks for any effort!!!
0 Likes
jferreira
Employee
Employee
10 sign-ins 5 sign-ins First like received
Hi,

I just imported your project. Generate code and compile and I could not reproduce the error.
Could you please make an screenshot showing the error in one of the affected files, i.e. sdmmc_block_conf.c

Best regards,
Jesus
0 Likes
Not applicable
Hi,


now I tried to took screenshoot of all folders where an error occurs.







2230.attach2231.attach2232.attach
0 Likes
Not applicable
Other two screenshoots



2233.attach2234.attach
0 Likes