Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

Jason_Lee
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted

Hi supporter

     我的modusToolbox在加载离线库时,总是在loading device_db时提示错误。信息如下:

Finished download of file 'file:///D:/ModusToolbox/offline/manifests-v2.X/mtb-wifi-mw-manifest.xml'

Finished download of file 'file:///D:/ModusToolbox/offline/manifests-v2.X/mtb-wifi-mw-manifest-fv2.xml'

Finished download of file 'file:///D:/ModusToolbox/offline/manifests-v2.X/mtb-wifi-mw-dependencies-manifest.xml'

Finished loading the manifest data (377 ms)

Loading the device db

fatal: 'D:ModusToolboxoffline/git/https___github.com_Infineon_device-db/device-db' does not appear to be a git repository

fatal: Could not read from remote repository.

Please make sure you have the correct access rights

and the repository exists.

ERROR:there was an error retreiving the asset 'https://github.com/Infineon/device-db' commit 'release-v4.0.2' - fatal: 'D:ModusToolboxoffline/git/https___github.com_Infineon_device-db/device-db' does not appear to be a git repository

ERROR:fatal: Could not read from remote repository.

ERROR:Please make sure you have the correct access rights

ERROR:and the repository exists.

ERROR:Global asset download of device-db loading completed with error.

ERROR:The asyncStepComplete failed for LoadFlag DEVICE_DB.

3 error(s), 0 warning(s)

我的Modus安装在自定义目录下,offline放在modustoolbox的安装目录下,环境变量已设置。出现这种错误是哪里配置的不对呢?

0 Likes
1 Solution
Vison_Zhang
Moderator
Moderator
Moderator
250 solutions authored 10 likes given 500 replies posted

这个错误有点像是 offline library 的版本与 MTB 的版本兼容性问题。 如果你使用的是 ModusToolBox 3.0 ,那么你需要使用最新版本的 offline library v1.3,之前的 v1.2 版本与 MTB 3.0 是不能兼容的。

最新版本 offline library 的下载请参考  https://community.infineon.com/t5/Resource-Library/ModusToolbox-Offline-Libraries/ta-p/252265

View solution in original post

0 Likes
3 Replies
Owen_Su
Moderator
Moderator
Moderator
50 solutions authored 100 sign-ins 100 replies posted

Hi, @Jason_Lee ,

    您正在使用的Mouds版本和offline package版本是哪一个呢?根据您的描述,您可以参考以下链接,检查一下您的安装过程是否有什么遗漏:https://community.infineon.com/t5/Knowledge-Base-Articles/ModusToolbox-software-Offline-development-...

https://community.infineon.com/t5/ModusToolbox-General/Project-Creator-2-0-BSP-has-a-problem-with-th...

    或者您可以尝试将这个repository放到报错的那个文件的位置: “D:ModusToolboxoffline/git”。您尝试之后如果还是不成功可以给我们进行反馈,希望这能对您有所帮助。

Regards,

Owen_Su

 

0 Likes
Vison_Zhang
Moderator
Moderator
Moderator
250 solutions authored 10 likes given 500 replies posted

这个错误有点像是 offline library 的版本与 MTB 的版本兼容性问题。 如果你使用的是 ModusToolBox 3.0 ,那么你需要使用最新版本的 offline library v1.3,之前的 v1.2 版本与 MTB 3.0 是不能兼容的。

最新版本 offline library 的下载请参考  https://community.infineon.com/t5/Resource-Library/ModusToolbox-Offline-Libraries/ta-p/252265

0 Likes
Owen_Su
Moderator
Moderator
Moderator
50 solutions authored 100 sign-ins 100 replies posted

    因为长时间未回复,这条thread将会被关闭,如果您还有其他的问题,可以再新建一条thread,感谢您的理解与支持。

Regards,

Owen_Su

0 Likes