Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

User12789
Level 3
Level 3
10 sign-ins First solution authored 5 sign-ins

I've got a KIT_XMC4400_DC_V1 board. This is a board intended for motor control and it has an XMC4400 onboard.

The board has two input ports for quadrature encoder inputs, but both ports accept differential encoder inputs and all of my motors have single ended encoders. Is there any way to use this board with single ended encoders?

0 Likes
1 Solution
User12789
Level 3
Level 3
10 sign-ins First solution authored 5 sign-ins

I tried connecting the single ended inputs to A+ and B+, but it didn’t work—the Posif always sees zeros. 

After looking at the board’s Schematics, I found that the Hall encoder inputs and quadrature encoder inputs both go to the same Posif inputs, so I just connected the quadrature signals from my motor to the Hall interface on the board and it works fine. The motor’s encoder outputs are strong enough that the pull-ups on the Hall inputs on the board don’t affect the signals.

View solution in original post

0 Likes
3 Replies
ncbs
Moderator
Moderator
Moderator
50 likes received 250 sign-ins 250 replies posted

Hi @User12789,

Can you connect the single ended inputs to A+, B+ and I+ of the encoder inputs and check the functionality?

Also, you may use the CCU4 unit to measure the pulse width/T_on time.

Regards,
Nikhil

0 Likes
User12789
Level 3
Level 3
10 sign-ins First solution authored 5 sign-ins

I tried connecting the single ended inputs to A+ and B+, but it didn’t work—the Posif always sees zeros. 

After looking at the board’s Schematics, I found that the Hall encoder inputs and quadrature encoder inputs both go to the same Posif inputs, so I just connected the quadrature signals from my motor to the Hall interface on the board and it works fine. The motor’s encoder outputs are strong enough that the pull-ups on the Hall inputs on the board don’t affect the signals.

0 Likes
ncbs
Moderator
Moderator
Moderator
50 likes received 250 sign-ins 250 replies posted

Hi @User12789,

Glad your query is resolved.

Please feel free to post any queries or issues you may have on Infineon products in the community and we will be happy to help.

Regards,
Nikhil

0 Likes