Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Not applicable
When I run debug mode by using new XMC1300 CPU Card, DAVE request to update J-link.
But update process is failure and get following message.
"J-link GDB Server failed:
Could not connect to target. Please check if target is powered and if ribbon cable is plugged properly.
For more details, seed the JlinkGDBServerCL console."

How can I fixed it?

JlinkGDBServerCL console message as below
==============================================
SEGGER J-Link GDB Server V5.12g Command Line Version

JLinkARM.dll V5.12g (DLL compiled May 27 2016 16:57:47)

-----GDB Server start settings-----
GDBInit file: none
GDB Server Listening port: 2331
SWO raw output listening port: 2332
Terminal I/O port: 2333
Accept remote connection: localhost only
Generate logfile: off
Verify download: on
Init regs on start: on
Silent mode: off
Single run mode: on
Target connection timeout: 0 ms
------J-Link related settings------
J-Link Host interface: USB
J-Link script: none
J-Link settings file: none
------Target related settings------
Target device: XMC1302-T038x0200
Target interface: SWD
Target interface speed: 1000kHz
Target endian: little

Connecting to J-Link...
J-Link is connected.
Firmware: J-Link Lite-XMC4200 Rev.1 compiled Jan 14 2016 11:19:27
Hardware: V1.00
S/N: 591025313
Checking target voltage...
Target voltage: 3.30 V
Listening on TCP/IP port 2331
Connecting to target...ERROR: Could not connect to target.
Target connection failed. GDBServer will be closed...Restoring target state and closing J-Link connection...
Shutting down...
0 Likes
1 Reply
Not applicable
It is just power Isolated issue.
When I provide the 5V power from inverter board, the problem is fixed.
0 Likes