Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

NarendraC
Level 1
Level 1
First solution authored 5 sign-ins First reply posted

Hello,

I am finding below errors like groovy objects not found and problem occured while restoring the project data. but compilation is happening.

I just cloned the project from Git Repo.

kindly help in this

NarendraC_0-1672749582131.png

 

NarendraC_0-1672748449600.png

Thanks 

Narendra C

0 Likes
1 Solution
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi,

Could you check the suggestions in the following thread ?

1)It seems that the file was inadvertently added to the ignore-list of git.
We removed it manually by opening the /DAVE/Model/.gitignore file with the editor and delete the listed "projectData.bin" from this file.

2)I could resolve the issue using a tool named "Directory Compare", which I used to compare a checkout from GIT which showed the problem and a working local copy which was pushed to git. It turned out that several folders and .app files
were missing in the Dave directory. The Dave/Model/APPS/* directory was affected. I can recommend this tool to investigate this sort of issue. -> You may use tools like BeyondCompare too.

Best Regards,
Vasanth R S

View solution in original post

0 Likes
2 Replies
Vasanth
Moderator
Moderator
Moderator
250 sign-ins 500 solutions authored First question asked

Hi,

Could you check the suggestions in the following thread ?

1)It seems that the file was inadvertently added to the ignore-list of git.
We removed it manually by opening the /DAVE/Model/.gitignore file with the editor and delete the listed "projectData.bin" from this file.

2)I could resolve the issue using a tool named "Directory Compare", which I used to compare a checkout from GIT which showed the problem and a working local copy which was pushed to git. It turned out that several folders and .app files
were missing in the Dave directory. The Dave/Model/APPS/* directory was affected. I can recommend this tool to investigate this sort of issue. -> You may use tools like BeyondCompare too.

Best Regards,
Vasanth R S

0 Likes

Hi 

Thanks for the inputs,

 I found two .App files are missing from Dave/Model/APPS/ folder

So,Copied DIGITAL_IO_90.APP,SPI_CONFIG_0.APP files from previous commit.

Now project is building without any object groove errors.

But How does the .APP files misses?

Issue is fixed now

Thanks

Narendra C

 

0 Likes