Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Not applicable
Hi,

I bought some time ago a xmc2go and did my first steps with dave. I use dave3 at the moment and try to measure a simple rectangular signal form a function generator.
I downloaded the CAP001_Example1_XMC11, did a migration to the xmc2go and started testing. It worked fine.

Now I reconfigured the peripherals. I used IO002 as Input for the rectangular signal and deleted the PWMSP001 App. Now I could measure the signal from my external function generator.
That worked fine. Now I started to increase the frequency from 5kHz to higher ones.

I was a little bit surprised, if I try to measure frequencies higher than 75kHz, the microcontroller doesn't react anymore. Only when I stop the output of my function generator or I decrease frequency,
then I can control the uc again.

Then I tried to use CAP001 without an interuppt, because I thought the uc is trapped in the interrupt.
I built a small state machine, started and stopped the CAP001 App with CAP001_Start and CAP001_Stop and tried to get the values of the period.
That worked fine for frequencies below 75kHz. It's the same behaviour as mentioned before.

Isn't it possible to measure higher frequencies than 75kHz with XMC2Go and CAP001? And why?

Thanks in advance!
0 Likes
2 Replies
Not applicable
Now it works... 😉
0 Likes
Rick_Nardone
Employee
Employee
Hi Wasi,

You might consider moving up to the latest version of the development tools, DAVE v4.1.2 www.infineon.com/dave


Best,

Rick
0 Likes