英飞凌 XMCflasher报错无法打开

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Sireky
Level 1
Level 1
First like given First solution authored First reply posted

下载了XMCFlasher后,无法打开,报错显示“A Java exception has occurred”,接着又下载了JAVA 8 JRE,但依然显示此类报错,仍然无法打开,请求帮助解决

Sireky_0-1704458945844.png

0 Likes
1 Solution
Sireky
Level 1
Level 1
First like given First solution authored First reply posted

英飞凌XMCFlasher是JAVA编写的软件,要正常运行需要配好的JAVA运行环境,在我遇到问题的时候,此时已有JAVA21,但可能由于XMCFlasher推出较早,不能适配较新的JAVA环境(我猜测的一种可能性),所以推荐配置JAVA8(JAVA 8被认为是一个相对稳定的版本),配置JAVA环境的方法推荐在CSDN内进行查询,然后照猫画虎进行配置,最后在Windows命令行内查看环境是否配置好,配置好后即可正常启动运行XMCFlasher

Sireky_0-1704507082504.png

 

View solution in original post

0 Likes
2 Replies
Sireky
Level 1
Level 1
First like given First solution authored First reply posted

英飞凌XMCFlasher是JAVA编写的软件,要正常运行需要配好的JAVA运行环境,在我遇到问题的时候,此时已有JAVA21,但可能由于XMCFlasher推出较早,不能适配较新的JAVA环境(我猜测的一种可能性),所以推荐配置JAVA8(JAVA 8被认为是一个相对稳定的版本),配置JAVA环境的方法推荐在CSDN内进行查询,然后照猫画虎进行配置,最后在Windows命令行内查看环境是否配置好,配置好后即可正常启动运行XMCFlasher

Sireky_0-1704507082504.png

 

0 Likes
lock attach
Attachments are accessible only for community members.
LinglingG_46
Moderator
Moderator
Moderator
500 solutions authored 1000 replies posted 10 questions asked

我的Flasher是按照这个流程下载安装的,可以正常使用:

在Infineon官网直接搜索XMCFlasher下载安装,还需要一些环境配置。一个是J-Link驱动,需要J-Link5.12版本及以上;另一个是JAVA环境,需要Oracle JAVA™ JRE 1.8.0_72版本及以上。
J-Link下载直接去J-Link官网即可,地址:https://www.segger.com/downloads/jlink/,根据需要的版本和电脑配置下载安装。
Oracle JAVA™ JRE在Oracle官网搜索JAVA即可,地址:https://www.oracle.com/cn/java/technologies/downloads/,在网页中找到JAVA™ JRE下载安装即可,这个需要注册一个Oracle账号,但是下载是免费的,安装包加载在附件里面。