Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

followed the quick start guide.

renamed my working make target from "snip.bluetooth.ble_proximity_reporter-BCM943341WCD1 download run" to "snip.bluetooth.ble_proximity_reporter-BCM943341WCD1-debug download"

clicked "snip.bluetooth.ble_proximity_reporter-BCM943341WCD1-debug download" and am able to see app build and download on console:

snip_bluetooth_ble_proximity_reporter-BCM943341WCD1-debug

----------------------------------|---------|---------|

                                  |         |  Static |

              Module              |  Flash  |   RAM   |

----------------------------------+---------+---------|

:

----------------------------------+---------+---------|

TOTAL (bytes)                     |  657236 |   53084 |

----------------------------------|---------|---------|

Downloading Bootloader ...

No changes detected

Download complete

Downloading DCT ...

No changes detected

Download complete

Downloading Application ...

No changes detected

Download complete

Build complete

Making .gdbinit

However when I click the green bug icon I get the following prompt :

The selection cannot be launched, and there are no recent launches.

0 Likes
2 Replies
VikramR_26
Employee
Employee
25 sign-ins 10 sign-ins 10 comments on KBA

make sure you following this steps

https://community.broadcom.com/community/wiced-wifi/wiced-wifi-forums/blog/2014/05/09/creating-andor...

Which version of SDK are you using ?

0 Likes
Anonymous
Not applicable

I am using WICED-SDK 3.5.2 and a BCM4343W iot starter kit. I have followed instructions from Creating and/or Editing Debug Configurations and still have some issues.

Error log:

7:06:12 **** Incremental Build of configuration Default for project WICED-SDK ****

"C:\\Users\\pihlungpang\\Documents\\WICED\\WICED-SDK-3.5.2\\WICED-SDK\\make.exe" Default

MAKEFILE MAKECMDGOALS=Default OTA2_SUPPORT is disabled

Making config file for first time

tools/makefiles/wiced_config.mk:224: *** Unknown component: Default.  Stop.

make: *** No rule to make target 'build/Default/config.mk', needed by 'main_app'.  Stop.

17:06:14 Build Finished (took 1s.969ms)

But "build/Default" directory doesn’t exist!


Here is the line in bold that should cause the trouble "tools/makefiles/wiced_config.mk:224:"

# Check if there are any unknown components; output error if so.

$(foreach comp, $(COMPONENTS), $(if $(wildcard $(foreach dir, $(addprefix $(SOURCE_ROOT),$(COMPONENT_DIRECTORIES)), $(dir)/$(subst .,/,$(comp)) ) ),,$(error Unknown component: $(comp))))

I tried to run the gdb and gdb --version from command terminal and it start up without any problems!

Would prefer to get WICED/Eclipse GUI to work but otherwise what will it take to run gdb from command line?

Thanks

0 Likes