cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

AxLi_1746341
Honored Contributor

On ThreadX build:

WICED_TLS_MINOR_VERSION_MIN=0 && WICED_TLS_MINOR_VERSION_MAX=0 works

WICED_TLS_MINOR_VERSION_MIN=0 && WICED_TLS_MINOR_VERSION_MAX=1 works

WICED_TLS_MINOR_VERSION_MIN=0 && WICED_TLS_MINOR_VERSION_MAX=2 fails

On FreeRTOS build

WICED_TLS_MINOR_VERSION_MIN=0 && WICED_TLS_MINOR_VERSION_MAX=0/1/2 all fails

For the failure case, sometimes I got join result 1007, and sometimes it just hang.

grsr

The test result is similar to the PEAP test.

So the enterprise security does not work for FreeRTOS+LwIP build at all.

0 Likes
4 Replies
GauravS_31
Moderator
Moderator

axel.lin_1746341

The issue with FreeRTOS has been reproduced. However, I could not reproduce it with ThreadX, TLSv1.2. Please provide your setup details:

Freeradius version

Ubuntu version

Openssl version

Platforms tested

0 Likes
AxLi_1746341
Honored Contributor

grsr wrote:

axel.lin_1746341

The issue with FreeRTOS has been reproduced.

So how is the status now? Does it work in sdk-6.2?

0 Likes
AxLi_1746341
Honored Contributor

grsr wrote:

axel.lin_1746341

The issue with FreeRTOS has been reproduced.

It has been more than 6 months since you replied you can reproduce the issue with FreeRTOS build.

Can you confirm if upcoming 7.0 release will fix this issue?

0 Likes
AxLi_1746341
Honored Contributor

FYI: When test EAP-TTLS in debug build of freeRTOS build.

I always hit assertion:

pbuf_header_impl (p=0x2000bd62 <memp_memory_PBUF_POOL_RX_base+3410>, header_size_increment=11689, force=0 '\000') at WICED/network/LwIP/ver2.0.3/src/core/pbuf.c:641

641     LWIP_ASSERT("bad pbuf type", 0);

(gdb) l

636        * bail out unsuccessfully */

637       return 1;

638     }

639   } else {

640     /* Unknown type */

641     LWIP_ASSERT("bad pbuf type", 0);

642     return 1;

643   }

644   /* modify pbuf length fields */

645   p->len += header_size_increment;

(gdb) p type

$1 = 139

The variable p->type shows different values in different test.

Something is very wrong in sdk-6.2.1.