Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

AxLi_1746341
Level 7
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA

Running scan snip code for a nearby AP with WPA2 AES enterprise security, got below output:

2 Infra BA:55:10:CF:AA:D0 -48 144.4    6     AES Enterprise       TEST-WPA2-ENT                             PROBE

It shows "AES Enterprise" rather than "WPA2 AES Enterprise".

I'm not sure if this is intentional but this seems wrong because

"AES Enterprise" is not a valid wiced_security_t.

I would expect "WPA2 AES Enterprise" in this case.

0 Likes
1 Solution

Hello:

seems we missed the WPA2 set in enterprise mode, please modify below setting in wwd_wifi.c for a try .

            if ( akm_suite_list_item == (uint32_t) WICED_AKM_8021X )

            {

                record->security |= WPA2_SECURITY;  //add this line

                record->security |= ENTERPRISE_ENABLED;

            }

View solution in original post

4 Replies
Zhengbao_Zhang
Moderator
Moderator
Moderator
First comment on KBA 10 questions asked 5 questions asked

Hello:

  I have a check on the print functio, it shows WPA2 AES Enterprise . 

( record->security == WICED_SECURITY_WPA_MIXED_ENT    ) ? "WPA Mixed Enterprise" :

  ( record->security == WICED_SECURITY_WPA2_TKIP_ENT    ) ? "WPA2 TKIP  Enterprise" :

  ( record->security == WICED_SECURITY_WPA2_AES_ENT     ) ? "WPA2 AES   Enterprise" :

  ( record->security == WICED_SECURITY_WPA2_MIXED_ENT   ) ? "WPA2 Mixed Enterprise" :

0 Likes

FYI, I tested on sdk-6.4.

So you can check print_scan_result() function.

You can run scan snip code on sdk-6.4 to confirm this issue.

0 Likes

sure, will have a try.

0 Likes

Hello:

seems we missed the WPA2 set in enterprise mode, please modify below setting in wwd_wifi.c for a try .

            if ( akm_suite_list_item == (uint32_t) WICED_AKM_8021X )

            {

                record->security |= WPA2_SECURITY;  //add this line

                record->security |= ENTERPRISE_ENABLED;

            }