Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

Anonymous
Not applicable

Hi,

I am using WiFi SDK 3.1.2. SN8205.

Has anyone uncommented WICED_ENABLE_MCU_RTC and tried reading the RTC timestamp with Powersave enabled?

The time lags a lot.

Does is mean WICED has no high accuracy clock to maintain time?

Regards,

Karthik

Edit - The hardware has the 32Khz crystal.

0 Likes
1 Solution
Anonymous
Not applicable

The issue is the powersave implementation.

When the device goes into powersave, the RTC clock frequency is changes from 1Hz to 800Hz.

During this transition from 1Hz to 800Hz, the sub second information is unaccounted causing the recalculation of RTC time to be inaccurate.

This issue may be see if a STM32F2 MCU is use.

Conclusion - If you need RTC to maintain perfect time do not opt for STM32F2 with powersave option enabled. Would suggest to opt for STM32F4.

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable

Hi,

Can Broadcom confirm if WICED supports high accuracy RTC and Powersave simultaneously?

Regards,

Karthik

0 Likes
Anonymous
Not applicable

The issue is the powersave implementation.

When the device goes into powersave, the RTC clock frequency is changes from 1Hz to 800Hz.

During this transition from 1Hz to 800Hz, the sub second information is unaccounted causing the recalculation of RTC time to be inaccurate.

This issue may be see if a STM32F2 MCU is use.

Conclusion - If you need RTC to maintain perfect time do not opt for STM32F2 with powersave option enabled. Would suggest to opt for STM32F4.

0 Likes