Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
JaJa_4678591
Level 1
Level 1

When I run the installer based on the instructions here: WICED-Studio 6.4.0 Installer (Linux)

I get

"

pi@raspberrypi:~/Downloads $ ./WICED-Studio-6.4.0.61-IDE-Installer.bin

Preparing to install

Extracting the JRE from the installer archive...

Unpacking the JRE...

Extracting the installation resources from the installer archive...

Configuring the installer for this system's environment...

Launching installer...

JRE libraries are missing or not compatible....

Exiting....

"

What extra prerequisite JRE libraries should I install on Raspbian Buster?

(The default JRE package says "This dependency package points to the Java runtime, or Java compatible runtime recommended for this architecture, which is openjdk-11-jre for armhf." but the installer instructions say JRE > 9 is not supported)

0 Likes
1 Solution
JoYi_1844281
Level 6
Level 6
100 sign-ins 100 replies posted 50 likes received

I don't think the toolchain include in WICED SDK could run under RasperryPi!

Even you successful install the WICED SDK under Raspbian buster!

SDK toolchain is for x86_64 HOST only!

View solution in original post

2 Replies
KotnaniK_71
Employee
Employee
50 likes received 25 likes received 10 likes received

Hi,

I am sorry to inform you that we haven't tested installing WICED 6.4 on Raspbian buster.

Can you please let us know the reason for installing WICED 6.4 in Raspberry pi and the Pi model which you're using.

Thanks.

JoYi_1844281
Level 6
Level 6
100 sign-ins 100 replies posted 50 likes received

I don't think the toolchain include in WICED SDK could run under RasperryPi!

Even you successful install the WICED SDK under Raspbian buster!

SDK toolchain is for x86_64 HOST only!