Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Not applicable

I have abandoned trying to use my J-link in favor of an Olimex JTAG_ARM-USB-OCD-H dongle.

I am trying to configure WICED to use it but I am still getting the OpenOCD failure at the boot-load stage.

I have loaded the requisite drivers and my device manager shows…


                Olimex OpenOCD AMR-USB-TINY-H

                Olimex OpenOCD JTAG ARM USB-TINY-H (Interface 0)

I am reasonably sure that my Olimex dongle is properly wired because I can start OpenOCD as follows:

openocd -f ./interface/ftdi/olimex-arm-usb-tiny-h.cfg

                 -f interface/ftdi/olimex-arm-jtag-swd.cfg

                 -f ./target/stm32f4x.cfg <NL>

Open On-Chip Debugger 0.9.0-rc1 (2015-04-24-22:09)

Licensed under GNU GPL v2

For bug reports, read

Info : FTDI SWD mode enabled

adapter speed: 2000 kHz

adapter_nsrst_delay: 100

none separate

cortex_m reset_config sysresetreq

Info : clock speed 2000 kHz

Info : SWD IDCODE 0x2ba01477

Info : stm32f4x.cpu: hardware has 6 breakpoints, 4 watchpoints

You may have noticed, I am using the SWD interface and not JTAG.  I have the Olimex SWD adapter in between the dongle and the target.

In addition, I can start a PuTTY telnet session and manually interact with OpenOCD on the target board.

First questions:

  1. Must I start OpenOCD prior to running WICED ? 
  2. If so is so is there a way to make WICED do that for me?
  3. Is there something I need to do in WICED since I am using the SWD interface?

In WICED my Make Target entry is:

MyProgram CEL_WB4343WF3SP2  JTAG=Olimex_ARM-USB-TINY-H download

Next questions:

What settings do I need in each of the debug configuration tabs?

In Main I have:

C/C++ Applictions:   build/eclipse_debug/last_built.elf

Project: WICED_SDK

In the Debugger Tab I have:

<path> \WICED\WICED-SDK-3.5.2\WICED-SDK\tools\ARM_GNU\bin\Win32\arm-none-eabi-gdb.exe

Under remote target, in the JTAG device pull-down I chose OpenOCD (via pipe)

In the Startup Tab

In the checked box under Halt I have:

add-symbol-file build/eclipse_debug/last_bootloader.elf 0x8000000

This worked before I switched to the Olimex dongle and was using a Broadcom BCM Eval module prior to my target hardware.

"Load Image" is checked using project binary.

The first entry of the openocd_log.txt file after a download attempt is...

Open On-Chip Debugger 0.9.0-00029-gafd5db2-dirty (2015-05-29-18:47)

Licensed under GNU GPL v2

For bug reports, read

Info : only one transport option; autoselect 'jtag'

trst_and_srst separate srst_gates_jtag trst_push_pull srst_open_drain connect_deassert_srst

adapter speed: 1000 kHz

adapter_nsrst_delay: 100

jtag_ntrst_delay: 100

Warn : target name is deprecated use: 'cortex_m'


Warn : Using DEPRECATED interface driver 'ft2232'

Info : Consider using the 'ftdi' interface driver, with configuration files in interface/ftdi/...

Error: unable to open ftdi device: device not found

Sorry for all the exposition but I wanted to give as much information as possible to perhaps reduce some back and forth.

Any help convincing WICED to download my compiled program into my target via the Olimex dongle will get you included in my will.


5 Replies

William - I am having similar troubles trying to get my Olimex working.  I am looking into this.



Debugging with Olimex has an issue with Wiced-SDK-3.7.0.

Please replace the …/tools/OpenOCD/Win32/openocd-all-brcm-libftdi.exe  with attached openocd-all-brcm-libftdi.exe



Not applicable

Hi seyhan

Thank you for the exe.  I tried it and, alas, still no joy.

After the ****OpenOCD failed.... message, the openocd_log is showing:



     Warn : Using DEPRECATED interface driver 'ft2232'

     Info : Consider using the 'ftdi' interface driver, with configuration files in interface/ftdi/...

     Error: unable to open ftdi device: device not found


The problem is with the bootloader.  (build-> waf.bootloader-NoOS-CEL_WB4343WF3SP2)

If I use the PuTTY TELNET connection and download a .ELF file, it appears to transfer to the target.

Then If I force the debugger to start within WICED I can single step through the init code although I never seem to get as far as the ELF code I loaded.  I get a watchdog trap instead.  But my point is that I seem to be able to do everything but boot-load through WICED.  Bear in mind that I am using the SWD interface as opposed to the JTAG interface.

I just have the feeling that I am just a setting or two away from success but with all these abstraction layers I just can't figure out what to set.

Over the weekend I ever tried all this at home using a fresh install just in case I set something wrong during these last 2 painful weeks.

Any thoughts on how to get the boot-loader to work?

Best regards


Not applicable

The people at CEL provided me with a programming board that seems to solve my download problems.  No more Segger or Olimex.  No more SWD vs JTAG.  This board uses a FTDI chip similar to the Broadcom Eval module I was using.  Happy Happy day!

I re-installed WICED just to undo all the stuff I was tweaking for a fresh beginning.

I have new platform files that CEL provided describing thier module and added them to the platforms folder.  The CEL module is very similar to the BCM94343WWCD1 platform so porting should be simple. 

I can compile download and run with no problems.  But when I try to compile debug and download I have a problem when I try to start the debugger.  I get an error that says.

     tools/makefiles/ *** No application specified. Options are: waf test README.txt wwd snip demo.  Stop.

     make: *** No rule to make target 'build/CEL_WB4343SP2/', needed by 'main_app'.  Stop.

I added some print statements in the script that shows what the variable APP is set to.  When I compile if shows the name of the program.  But when I debug APP is empty.

If I ignore the error, and enter the debugger, it is stating in the console in red that

      No source file named apps/snip/program_name/program_name.c

This happens even with the WICED program examples such as snip.scan.

I have tried all sorts of settings based on these and other forums and quick start guides. And I swear that I had this working properly back when I was using the Broadcom eval module but even that module behaves this way now.

I am so close to getting productive again I can taste it.

Thanks for any help



Thanks for the update Bill.

I'm adding the cortettechsupport​ team here as well.