Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

DaEg_3292701
Level 1
Level 1
First like received First like given

Regararding: WICED 6.1 won't install - continually asks to choose a different location

FWIW I can install it on macOS but it won't run. Very annoying.

Apart from the ridiculous installer (which is not Retina compatible and follows many bad practises like asking for a password), the totally bogus default installation location, I'm only getting a ton of non-saying error messages in a log I locations that's annoying to get to, it goes something like this...

!SESSION 2018-04-12 21:29:50.148 -----------------------------------------------

eclipse.buildId=4.4.2.M20150204-1700

java.version=10

java.vendor=Oracle Corporation

BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_GB

Framework arguments:  -product org.eclipse.epp.package.cpp.product -keyring /Users/egger/.eclipse_keyring -showlocation

Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -product org.eclipse.epp.package.cpp.product -keyring /Users/egger/.eclipse_keyring -showlocation

!ENTRY org.eclipse.cdt.autotools.core 4 0 2018-04-12 21:29:51.044

!MESSAGE FrameworkEvent ERROR

!STACK 0

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.cdt.autotools.core [43]

  Unresolved requirement: Require-Bundle: org.eclipse.cdt.managedbuilder.core; bundle-version="5.0.100"

    -> Bundle-SymbolicName: org.eclipse.cdt.managedbuilder.core; bundle-version="8.3.0.201502131403"; singleton:="true"

       org.eclipse.cdt.managedbuilder.core [78]

         Unresolved requirement: Require-Bundle: org.eclipse.cdt.core; bundle-version="[5.0.0,6.0.0)"

           -> Bundle-SymbolicName: org.eclipse.cdt.core; bundle-version="5.9.1.201502131403"; singleton:="true"

              org.eclipse.cdt.core [53]

                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

        at org.eclipse.osgi.container.Module.start(Module.java:434)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)

        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)

        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)

        at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

0 Likes
1 Solution

If you check the installation notes WICED-Studio-6.2.1 (OSX) , there is a link provided to install Java SE 8 and then check the version from the terminal. If the version still returns an old version, the command sequence that you have to follow to correctly link the updated Java is also mentioned. In my system, I have installed Java SE 8 from the mentioned link and WICED Studio works perfectly for me. BTW, which Java version is currently installed in your system? I would recommend removing the older version (example command uses 1.6 version, choose your version) of Java by using sudo rm -rf /Library/Java/JavaVirtualMachines/1.6.0.jdk/  before proceeding with the fresh installation.

View solution in original post

0 Likes
10 Replies
RaktimR_11
Moderator
Moderator
Moderator
500 likes received 250 likes received 100 likes received

I understand your frustration to get the WICED Studio up and running. Installation procedure should be hassle-free at the very least. We are continuously working on making the installation procedure easier which is where your comments will help us to get better.

By looking at your log, it seems like a Java version mismatch. Required Java SE version is 1.7 and you have some other version installed on your system. Please check the existing version and then try to install the 1.7 version as required by the SDK. If I am not wrong, you should see this version error pop-up when you try to launch WICED Studio in MAC (No need to dig through the log, a painful process indeed)

There's no error mismatch window. The installed version is "java 10 2018-03-20" which was recommended by some other tools I'm using and it seems a regular Eclipse and various other Eclipse based IDEs/plugins (like MCUXpresso, STM32CubeMX and more) work just fine with it.

0 Likes

Open x-term, run the java -version command and check the return. Please go through the additional installation notes as provided in WICED-Studio-6.1.0 (OSX)

0 Likes

That's what I did but happy to do it again:

java version "10" 2018-03-20

Java(TM) SE Runtime Environment 18.3 (build 10+46)

Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10+46, mixed mode)

0 Likes
DaEg_3292701
Level 1
Level 1
First like received First like given

rroy

So I just tried the latest 6.2 version and followed the instructions in WICED-Studio-6.2 (OSX) but it still does not work. FWIW the hint with Java version 1.7 could indeed be the culprit as that's what the log indicates. However if it exclusively works with a heavily outdated version of Java which cannot even be regularly downloaded anymore then that's a serious flaw by itself. It really should work with Jave SE 7 or higher and in fact the mentioned document above even recommends to install Java SE 8...

0 Likes

If you check the installation notes WICED-Studio-6.2.1 (OSX) , there is a link provided to install Java SE 8 and then check the version from the terminal. If the version still returns an old version, the command sequence that you have to follow to correctly link the updated Java is also mentioned. In my system, I have installed Java SE 8 from the mentioned link and WICED Studio works perfectly for me. BTW, which Java version is currently installed in your system? I would recommend removing the older version (example command uses 1.6 version, choose your version) of Java by using sudo rm -rf /Library/Java/JavaVirtualMachines/1.6.0.jdk/  before proceeding with the fresh installation.

0 Likes

If you go back the thread you might see that I'm actually using a newer version than 8 and all software runs perfectly fine with it (including all products from competition like ST and NXP), only Wiced Studio craps out. Coincidentally it actually works on my other Mac with the exact same JDK but on macOS El Capitan instead of macOS Sierra.

I totally get it that Cypress is a complete stranger to non-Windows OSes, but if you're going to offer cross platform software you might want to hire someone who actually has a clue: The installer is the horror and totally not Mac. It recommends ridiculous installation places, is not "Retina" display friendly, the sandboxing workaround can only be meant as an April fools joke and where the heck did you get the idea that asking for the administrator password in some shady installer is even close to acceptable?

Hey, so sorry about all the install problems you have had. That is the first exposure many people have to Cypress so it sucks when it's not smooth. I can't address the Java version issue, but I know a little about our nextgen installer. It will use normal drag and drop on the Mac. That is

- User downloads a DMG (disk image file).

- Double clicking it opens in the Finder (the Mac file explorer).

- User can drag+drop the tool folder anywhere they like.

Best regards,

--Matt

0 Likes

4 years later and it seem the app still requires that ancient Java version! Has anyone found any workarounds to that?

0 Likes

Look at the timing the issue is reproted (on 4/12).

If people need to address the installer issue for more than 2 months, it's indeed a problem.

I'd suggest cypress also provide sdk in tarball file which is easier for non-windows users to install it if hitting install issue.