Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

Hi,

I am using WICED Wifi BCM943362WCD4 eval board to interface with RS 485 through UART. I am using IC SP3485CP (Half duplex RS 485 Tranceiver) based circuit for communication between RS 485 bus and WICED board.

I want to use the RTS pin in WICED_UART_2 to control the direction in Tranceiver (SP3485CP). But whenever I transmit bytes from UART, I cannot see any change in the voltage level of RTS pin .

I have configured UART as shown below.

wiced_uart_config_t uart_config_meter_tx =

{

  .baud_rate    = 9600,

  .data_width   = DATA_WIDTH_8BIT,

  .parity       = EVEN_PARITY,

  .stop_bits    = STOP_BITS_1,

  .flow_control = FLOW_CONTROL_RTS,

};

wiced_uart_init( WICED_UART_2, &uart_config_meter_tx, &rx_buffer_one );

I transmit bytes using the following function.

wiced_uart_transmit_bytes( WICED_UART_2, (const char *)tx_data, 7)

The bytes are getting successfully transmitted as seen on CRO on Tx pin of UART but RTS is not seen to toggle. (As per platform.c WICED_GPIO_11 is the RTS pin which I am monitoring)

Any idea how to get this working or is RTS pin not connected in this board?

Thanks.

0 Likes
1 Solution
Anonymous
Not applicable

RTS for USART2 is WICED_GPIO_2 I think.

Could you double-check Wiced/Platform/BCM943362WCD4/platform.c?

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable

RTS for USART2 is WICED_GPIO_2 I think.

Could you double-check Wiced/Platform/BCM943362WCD4/platform.c?

0 Likes
Anonymous
Not applicable

my mistake. Thank you.

0 Likes