Announcements

Help us improve the Power & Sensing Selection Guide. Share feedback

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

Hi,

I'm trying to download images using OpenOCD, but errors occured, any suggestion? Here is the log:

Open On-Chip Debugger 0.9.0-00029-gafd5db2-dirty (2015-05-29-18:47)

Licensed under GNU GPL v2

For bug reports, read

  http://openocd.org/doc/doxygen/bugs.html

trst_and_srst separate srst_nogate trst_push_pull srst_push_pull connect_assert_srst

adapter speed: 1000 kHz

adapter_nsrst_delay: 100

Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.

jtag_ntrst_delay: 100

Warn : target name is deprecated use: 'cortex_m'

jtag_init

Error: libusb_open() failed with LIBUSB_ERROR_NOT_FOUND

Error: Cannot find jlink Interface! Please check connection and permissions.

I've installed the follow USB lib and the devices manager shows it as "J-Link driver(Interface 2)(Interface 2)".

http://sourceforge.net/projects/libusb-win32/files/libusb-win32-releases/1.2.6.0/libusb-win32-bin-1....

0 Likes
5 Replies
Anonymous
Not applicable

I'm using Win7_64.

0 Likes
Anonymous
Not applicable

new error message:

Warn : target name is deprecated use: 'cortex_m'

jtag_init

Error: J-Link command 0x01 failed (0)

Error: J-Link command EMU_CMD_VERSION failed (0)

Info : J-Link JTAG Interface ready

Error: J-Link command 0xdd failed (0)

Error: J-Link command 0xdf failed (0)

Error: J-Link setting speed failed (0)

Error: usb_bulk_write failed (requested=6, result=0)

Error: jlink_tap_execute failed USB io (-107)

Error: J-Link setting speed failed (0)

0 Likes

Hi bgv112233

I am getting exactly same problem. Any luck resolving it.

Shishir

0 Likes
Anonymous
Not applicable

Hi bgv112233 ,

I have same message from openocd_log as yours.

Do you resolve your issue ?

Please share your experience to me and thank you.

0 Likes

I can see that you are using OpenOCD 0.9.0, I did not manage to get my j-link working using this version, so I manually rolled OpenOCD back to version 0.8.0 (which is included in some of the older SDK releases), and this solves the issue for me.

I later moved to a Olimex based JTAG, which works fine with OpenOCD 0.9.0.