Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

Anonymous
Not applicable

Hello,

I am reporting this issue on behalf of my cusomer, he has installed the WICED-SDK-2.3.1-IDE-Installer.exe file. However, when they run this file they get an error message, attached here. The program asks to install JRE first. The thing is that they have already installed the JRE and the Java SDK as well from oracle website. The machine is running Windows 7 64bit.

Any ideas on how to progress ?

Thank you

Mark Hughes

0 Likes
1 Solution
Anonymous
Not applicable

The WICED SDK contains a 32-bit version of an Eclipse based IDE which requires a 32-bit versoin of JRE to be installed. If you have the 64-bit JRE installed you will need to install the 32-bit version as well.

JRE is designed to allow both 32 and 64 bit variants to be installed on the same system.

We have updated the error message reported by the installer to indicate that a 32-bit JRE must be installed as the 64-bit version is not compatible.

View solution in original post

20 Replies
Anonymous
Not applicable
Apologies for the late reply.

Did your customer manage to solve the problem?
0 Likes
Anonymous
Not applicable
Apologies for the late reply.

Did your customer manage to solve the problem?

Greetings Sir,

No i still get the same problem. I am sure that i have the lates java SDK installed.

Best Regards
0 Likes
Anonymous
Not applicable

Is there a resolution to this issue?  I'm having the same problem on the same platform (Windows 7 64, JRE up to date).  WICED SDK is useless until I can get around this.

0 Likes
Anonymous
Not applicable

Have you tried the latest 2.4.0 SDK?

We recommend to everyone that they should update to the latest SDK to ensure they get latest fixes and improvements.

0 Likes
Anonymous
Not applicable

I am using SDK V2.4.0.  Any suggestions to get around this JRE issue?

0 Likes
Anonymous
Not applicable

I've been looking into this and found our installation scripts check for the existence of a key in the Windows registry:

HKLM "SOFTWARE\JavaSoft\Java Runtime Environment\CurrentVersion"

From my investigation it appears that the "CurrentVersion" key is missing from some installations. I will work on modifying our scripts to detect the new registry key structure but in the mean time you can try manually creating that key in your registry and see if it fixes the problem.

If you aren't sure how to do that I can provide a file that will add that entry in a few days.

Anonymous
Not applicable

I tried adding the key but it did not help.  However, I simply added C:\Windows\System32 to my path (providing access to javaw.exe) and now the IDE loads properly.  Thanks for your help.

0 Likes
Anonymous
Not applicable

Stuart,

Thanks for feeding back your fix.

Just to clarify, were you unable to install the SDK because it failed to detect JRE as mentioned by Mark?

Or, once installed, did it fail to run the IDE?

Anonymous
Not applicable

Nicholas,

I had the same problem. (running windows7 professional 32 bit)

The SDK installed ok (v2.4).

When you run the program it says it can't find the java in a subdirectory of WICED. (The installer has not put it there!)

As Stuart pointed out, the javaw.exe is already in the system32 directory.

Seems to be a problem with the installer.

Regards

Philip

0 Likes
Anonymous
Not applicable

The SDK installer doesn't install the Java Runtime Environment. It is up to the user to install that prior to installing the SDK. The installer attempts to detect that the JRE has been installed but it does not verify that javaw.exe is accessible.

I'll feed that back to the development team so the installer can attempt to find the appropriate javaw.exe and put it in the PATH or modify the IDE shortcut to point to it directly.

Thanks for your help.

Anonymous
Not applicable

Hello,

Could you please explain to me what did you do exactly because i am trying to follow your steps but i get no result.

Best Regards

0 Likes
Anonymous
Not applicable

Asterios,

Can you describe what error you are seeing and the steps you took to install the SDK?

0 Likes
Anonymous
Not applicable

Hi, I have downloaded and installed WICED-Smart-SDK-1.1.0-IDE-Installer. However when I start the WICED Smart IDE, it says "Failed to create the Java Virtual Machine. " Please help. Thanks.

0 Likes
Anonymous
Not applicable

From this link: jvm - Eclipse Error: Failed To Create the Java Virtual Machine - Stack Overflow

It looks like there may be a number of causes involving the eclipse.ini file.

How much free RAM do you have?

Before doing any of the following be sure to create a backup of your eclipse.ini file.

You may need to modify the "-Xmx" flag to be "-Xmx512m" or "-Xmx256m"

You can also try removing the line starting with "-vm".

0 Likes
Anonymous
Not applicable

Hi Nicholas,

Thanks. after changing to '-Xmx128m', it works.

0 Likes
Anonymous
Not applicable

Greetings,

I am just trying to install the WICED SDK but just before the installation starts i get an error message that no Java is detected on my computer. However I am sure that have the latest JRE. In addition i have added the path to javaw.exe as an environmental PATH variable.

Best Regards,

Asterios

0 Likes
Anonymous
Not applicable

The WICED SDK contains a 32-bit version of an Eclipse based IDE which requires a 32-bit versoin of JRE to be installed. If you have the 64-bit JRE installed you will need to install the 32-bit version as well.

JRE is designed to allow both 32 and 64 bit variants to be installed on the same system.

We have updated the error message reported by the installer to indicate that a 32-bit JRE must be installed as the 64-bit version is not compatible.

Anonymous
Not applicable

GREAT this solved my problem,

this is the link for the correct JAVA SE version

Java SE Development Kit 7 - Downloads | Oracle Technology Network | Oracle

Select

Windows x86123.64 MB  http://download.oracle.com/otn-pub/java/jdk/7u51-b13/jdk-7u51-windows-i586.exe jdk-7u51-windows-i586.exe
Anonymous
Not applicable

Greetigs nikvh,

Thank you very much. This is the actual solution to the problem.

Best Regards,

Asterios

MiTo_1583836
Level 5
50 likes received 25 likes received 10 likes received
Level 5

There is one little detail that I would like to add. In case you install JRE via Internet Explorer make sure to run Internet Explorer 32-bit version and not the 64-bit. In case you run the IE 64-bit, the JRE 64-bit will be installed and the Broadcom SDK will still not run. I put together a list of steps as follow (current version of JRE is v8 update 40)

1) Open Internet Explorer 32-bit, NOT the 64-bit (very important)! From Start->All Programs->Internet Explorer (you should see both Internet Explorers listed, we don’t want to use the 64-bit).


2) Run this link: http://www.java.com/en/download/uninstallapplet.jsp


3) If you have the latest JRE installed you should see: “Congratulations! You have the recommended Java installed, Version X Update YZ” (as of 3/26/2015 X=8, Y=4, Z=0). If not proceed with the update. If you get the Congratulations message go to step 7.


4) When the update is done, close IE and open it again: same 32-bit version under: Start->All Programs->Internet Explorer

5) Access the page here again:  http://www.java.com/en/download/uninstallapplet.jsp

6) You should see now: “Congratulations! You have the recommended Java installed, Version X Update YZ” (as of 3/26/2015 X=8, Y=4, Z=0).

7) Go on the Broadcom Community Website with the same Internet Explorer: http://community.broadcom.com/docs/DOC-1042

😎 Click on WICED-Smart-SDK-1.1.0-IDE-Installer.exe, you should be downloading the SDK.

9) You should be able to start Broadcom Eclipse at the end of the installation.

0 Likes