Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

MilesHsu
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

I want to download the Wiced 4.0.1 to develop my product , I find the link:

https://community.cypress.com/t5/WICED-Studio-Wi-Fi-Combo/WICED-Studio-4-0-1-has-been-released/m-p/6...

but I can not download any file from the link.

The response is:"You do not have sufficient privileges for this resource or its parent to perform this action."

Could anyone help me to get Wiced 4.0.1 SDK ?  

0 Likes
6 Replies
SheetalJ
Moderator
Moderator 750 replies posted 500 likes received 500 replies posted
Moderator

Hi @MilesHsu ,

WICED 4.0.1 is a very old version and is now deprecated. I would suggest you to please use latest WICED SDK versions: https://www.cypress.com/products/wiced-software

Also, you can look at ModusToolbox- https://www.cypress.com/products/modustoolbox

 

0 Likes
AxLi_1746341
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA
Level 7

@SheetalJ wrote:

Hi @MilesHsu ,

WICED 4.0.1 is a very old version and is now deprecated. I would suggest you to please use latest WICED SDK versions: https://www.cypress.com/products/wiced-software

Also, you can look at ModusToolbox- https://www.cypress.com/products/modustoolbox

 


Is the firmware built with ModusToolbox compatible with WICED?
e.g. For existing WICED users, is it safe to OTA from WICED application firmware to new firmware built with ModusToolbox?
If not, ModusToolbox is not an option for existing WICED users.

I asked this because there is no update for WICED for quite long time.
Even the latest wiced-6.6 was released 1 year ago.
BTW, I think cypress/infineon should at least maintain WICED for bug fixes / security fixes.

0 Likes
MilesHsu
Level 1
10 sign-ins 5 sign-ins First reply posted
Level 1

Dear @SheetalJ 

My product is designed by the old version WICED 4.0.1 in 2016. Now I want to add some features for the product so I need to install WICED 4.0.1.

Could please you provide the SDK WICED 4.0.1 to me?

0 Likes
SheetalJ
Moderator
Moderator 750 replies posted 500 likes received 500 replies posted
Moderator

Hi @MilesHsu ,

As it is a deprecated version, we can't provide the version on community. Please check your Community message inbox.

0 Likes
ShawnA_01
Employee
25 solutions authored 10 solutions authored 5 solutions authored
Employee

<<<Is the firmware built with ModusToolbox compatible with WICED?

No.  The firmware for ModusToolBox is not compatible with WICED environments.   A WICED SDK 6.6.1 is expected soon but I believe the only changes are the new ExpressLogic (NetX and NetXDuo) Libraries to solve the "WRECK IP" vulnerability".

0 Likes
AxLi_1746341
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA
Level 7

Check the mbedTLS version and FreeRTOS version in WICED, you will find vulnerabilities that needs fix as well.

0 Likes