Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

Anonymous
Not applicable

I try to call

  if (wwd_wifi_set_channel( WWD_STA_INTERFACE, 5 ) != WWD_SUCCESS) {

    ....

and I get a good return status.  But when I enter monitor mode right afterwards:

  wwd_wifi_set_raw_packet_processor( process_raw_packet );

  wwd_wifi_enable_monitor_mode( );

It appears to give me packets from all channels as if it ignored the channel that I selected.  Is it wrong to set the channel in this way, and is there a way to set it in monitor mode?

Roger

0 Likes
1 Solution
JaeyoungY_71
Employee
100 likes received 50 likes received 25 likes received
Employee

Hi Roger,

The function wwd_wifi_set_channel() is for setting the channel to which the WICED device needs to operate at. It is not meant for setting the channel for monitoring.

The monitor mode in the function wwd_wifi_enable_monitor_mode( ); is meant to scan all channels. You can see the usage of this function in WICED/internal/wiced_cooee.c. I'm afraid there is no way to enable a single channel on monitor mode.


Thanks,

Jaeyoung

View solution in original post

1 Reply
JaeyoungY_71
Employee
100 likes received 50 likes received 25 likes received
Employee

Hi Roger,

The function wwd_wifi_set_channel() is for setting the channel to which the WICED device needs to operate at. It is not meant for setting the channel for monitoring.

The monitor mode in the function wwd_wifi_enable_monitor_mode( ); is meant to scan all channels. You can see the usage of this function in WICED/internal/wiced_cooee.c. I'm afraid there is no way to enable a single channel on monitor mode.


Thanks,

Jaeyoung