Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
Anonymous
Not applicable

Hello

we are considering to use STA and AP mode at the same time, For example, My WICED device in STA mode is connected with an external Wi-Fi AP, and also my Laptop’s Wi-Fi client is connected to the WICED device in AP mode of Wi-Fi, please see the below.

  * My Laptop (Wi-Fi Client) <-- Connected ---> WICED AP / STA <-- Connected ---> External Wi-Fi

First time those connection flow are working fine, but when My Laptop (Wi-Fi Client) disconnect and try to connect it again, and then the connection between My Laptop (Wi-Fi Client)  and WICED AP did not available as following.

  * My Laptop (Wi-Fi Client) <-- Did not connect ---> WICED AP / STA <-- Connected ---> External Wi-Fi

But if I try to use a new laptop on this follow and then the connection between them is etablished well, but if I try to disconnect and try it again and then the same issue were happened, so in order to establish a hew connection between them I have to use an anther laptop.

Would you please help me on this circumstance?

I'm using the WICED version to WICED-SDK-2.4.1, and in the WICED-SDK-2.4.0 version the issue did not happen although some of Wi-Fi features are not stable.


Thank you


Daniel

0 Likes
1 Solution
Anonymous
Not applicable

Yes, it was resolved, but the old wi-fi firmware is not stable for between laptop testing.

View solution in original post

40 Replies
Anonymous
Not applicable

We haven't seen this issue before in 2.4.1, but we'll try to reproduce it and get back to you asap.

0 Likes
Anonymous
Not applicable

Thanks gerdiman

I really appreciate your help and hear to your response soon as our customer request to use this function very importantly.

Thank you

Daniel

0 Likes
Anonymous
Not applicable

Hello gerdiman

I'm waiting for your response, would you please let me know any update for the issue?

Thank you

Daniel

0 Likes
Anonymous
Not applicable

We've managed to reproduce this issue on 2.4.1 and are currently working on a solution.

0 Likes
Anonymous
Not applicable

Thanks for your kindly response, and I really hope that this issue will be resolved soon.

0 Likes
Anonymous
Not applicable

Hello Gerdiman

I wish that when the solution will be available? because I have to apply this solution ASAP.
Would you please let me know the schedule or plan such as including new SDK?
I really hope that this solution will be provided soon.

Best Regards
Daniel

0 Likes
Anonymous
Not applicable

You may replace the BCM43362 WLAN firmware in WICED-SDK 2.4.1 with the one in 2.4.0. The firmware can be found in <WICED-SDK>/Wiced/WWD/internal/chips/43362a2/wifi_image.c.

0 Likes
Anonymous
Not applicable

Thank you for the feedback, but when the old Wi-Fi firmware is applied and then there is an issue between STA and AP, please see the below.

*Step1) My Laptop (Wi-Fi Client) <-- Not Connect ---> WICED AP / STA <-- Connected ---> External Wi-Fi
              The internet connection between STA and External Wi-Fi is working fine.

*Step2) My Laptop (Wi-Fi Client) <-- Connected ---> WICED AP / STA <-- Connected ---> External Wi-Fi
              The internet service between STA and External Wi-Fi did not available.

                  for example, during the STA is sending ping and whenever the connection between My Laptop and WICED AP is establided, the ping timeout is occured. 

And in the new Wi-Fi firmware of SDK 2.4.1 there is no issue on this matter although there is the new connection issue between My Laptop and WICED AP.

0 Likes
Anonymous
Not applicable

Which platform/board are you using?

0 Likes
Anonymous
Not applicable

I'm using the BCM9WCDUSI09 platform. Thank you

0 Likes
Anonymous
Not applicable

I haven't seen such issue with 2.4.0. I will need to try to reproduce it again tomorrow.

0 Likes
Anonymous
Not applicable

and we are using the USI WM-N-BM-09 Module, please see the below.

pastedImage_0.png

0 Likes
Anonymous
Not applicable

Please go head the reproduce work as it is very important for our current business. I hope to see you understand on it. Thank you.

0 Likes
Anonymous
Not applicable

I can't reproduce the ping issue that you reported with both 2.4.0. and 2.4.1. WLAN firmware.

What application are you running? Can you post it here?

0 Likes
Anonymous
Not applicable

I tried to use the aspta App in the Snip folder, and also update the wi-fi image as you request, so that I can reproduce the ping issue with the aspta app and the Wi-Fi firmware image of SDK 2.4.0 as following.

pastedImage_0.png

Would you please try to check it again?

Anonymous
Not applicable

Still can't reproduce it. This is what I see:

Capture.PNG

Does the ping recover afterwards or is it timing out forever?

Is the SDK 2.4.1 you're using is stock standard or there have been some changes added to it? I noticed the 'wiced_join_ap' string printed which normally isn't there.

Please try to upload a sniffer trace.

Another option is to try with a different access point.

0 Likes
Anonymous
Not applicable

No, the ping didn't recover after WICED_AP_INTERFACE were establied from my laptop's Wi-Fi.

and please see the another log which is connected the different acces point as you requested.

Starting Wiced v2.4.1

Platform BCM9WCDUSI09 initialised

Started ThreadX v5.5

Initialising NetX_Duo v5.6

Creating Packet pools

WWD SDIO interface initialised

WLAN MAC Address : FC:4D:D4:EF:90:75

WLAN Firmware    : wl0: Sep 18 2013 10:12:55 version 5.90.230.3 FWID 01-2046ff2b

wiced_join_ap

Joining : dyhome

Successfully joined : dyhome

Obtaining IPv4 address via DHCP

Setting IPv6 link-local address

IPv4 network ready IP: 192.168.1.2

Pinging 192.168.1.254 every 1000ms with a 900ms timeout.

Setting IPv6 link-local address

IPv4 network ready IP: 192.168.0.1

Ping Reply : 14 ms

Ping Reply : 1 ms

Ping Reply : 8 ms

Ping Reply : 18 ms

Ping Reply : 54 ms

Ping Reply : 3 ms

Ping Reply : 3 ms

Ping Reply : 773 ms   ===> Plz see that at this monent I tried to connect to WICED Soft AP.

Ping timeout

Ping Reply : 16 ms

wiced_link_events_handler event_type:46

link_up

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping timeout

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Ping error

Thank you

0 Likes
Anonymous
Not applicable

How about taking and checking air packet capture?

0 Likes
Anonymous
Not applicable

I just use the Putty tool which has the logging feature and capture through WICED serial port.

0 Likes
Anonymous
Not applicable

I see that you added prints to the WWD layer i.e. 'wiced_link_events_handler event_type' and 'link_up'.

These printfs run on WWD thread. WWD thread only has 600 bytes of stack space and printf requires at least 4K of stack space. The printf ends up blowing up the stack and will lead to unpredictable behaviour. Please remove those prints and retest. Or the easiest way is to test with a fresh WICED-SDK.

0 Likes
lock attach
Attachments are accessible only for community members.
Anonymous
Not applicable

Would you please check the attchement source code on your side? because I think that there is no the behavior.

0 Likes
Anonymous
Not applicable

Please make sure you've done what I've asked you to do in the previous post. That is important.

0 Likes
Anonymous
Not applicable

As you mention that I need to consider to the WWD thread stack which is limited the 600 bytes allocation, 

but I didn’t any change the apsta source code of snip in order to reproduce the issue only for modify for the SSID name and Wi-Fi password, and I ‘m not sure that what I need to remove the printf or how to use the fresh WICED-SDK? You mean that should I need to reinstall and install the WICED-SDK newly?  So I just attached the apsta source what I’m using in order to review on your side.


Would you please explain me more detaily? 

0 Likes
Anonymous
Not applicable

These prints aren't in the original SDK. If you get a fresh SDK reinstalled, you will notice that these prints aren't available by default. These prints aren't generated from snip.apsta.

0 Likes
Anonymous
Not applicable

Hello gerdiman, I tried to check on your suggestion, and when I reinstall the SDK 2.4.1 and then the ‘wiced_join_ap’ message didn’t appear, and also the ping session is retain sometimes. But unfortunately when I try to connect and reconnect the Wi-Fi connection between My laptop and WICED Soft AP about 1~4 times and then the ping issue is generated again.

pastedImage_0.png

0 Likes
Anonymous
Not applicable

Hello Gerdiman

Would you please let me know  your opinion or any update for the issue?

Thank you
Daniel

0 Likes
Anonymous
Not applicable

We really can't reproduce the issue over here. Please capture some sniffer trace for us to analyse. Thanks.

0 Likes
Anonymous
Not applicable

Hello Gerdiman

Would you please share your tested Wi-Fi firmware image to me?

Thank you

Daniel

0 Likes
Anonymous
Not applicable

<WICED-SDK>/Wiced/WWD/internal/chips/43362a2/wifi_image.c of WICED-SDK-2.4.0.

Another alternative is to test this with WICED-SDK-2.4.0 instead and check whether you can reproduce this issue.

0 Likes
Anonymous
Not applicable

Unfortunately in my environment the issue were happened continuously, however in the WICED SDK 2.4.1 the ping issue didn’t happen although there is the Wi-Fi reconnection problem. So I’m going to wait the new SDK version which is included the Wi-Fi reconnection issue, would you please share the schedule when it will be available?

0 Likes
Anonymous
Not applicable

What is the length of the ICMP ping request packet you're sending from your PC?

0 Likes
Anonymous
Not applicable

The ICMP ping request of my laptop is 74 length as following.

pastedImage_0.png

and normally my laptop didn't send the ping request to the WICED AP, but in the WICED Application send the ping request to the STA's gateway address.

0 Likes
Anonymous
Not applicable

Would you please let me know the release schedule for the Wi-Fi reconnection issue when it will be available? Because I have to announce the expected date to our customer on this project.

0 Likes
Anonymous
Not applicable

This thread has become very long so let me try to summarize some actions for you try.

1. Our plan to resolve this issue is to revert the 43362 WLAN firmware version 5.90.230.7 in WICED-SDK-2.4.1 with version 5.90.230.3 (WICED-SDK 2.4.0). Our tests show positive results when tested with firmware version 5.90.230.3.

2. You mentioned that you've tried reverting the firmware but encountering a new issue. We can't reproduce the new issue, so as mentioned before, please try to capture a sniffer trace when the issue is occurring and upload it here. That'll provide us some debug data to analyse, otherwise we can't proceed.

0 Likes
Anonymous
Not applicable

Thank you for cooperation for my consideration,

finally I’d checked the issue are only happened with my laptop’s Wi-Fi, but other laptop and smartphone and tablet devices are working fine based on the WICED-SDK-2.4.1 with version 5.90.230.3 (WICED-SDK 2.4.0). fortunately our service will work for smartphone devices, and therefore the Wi-Fi compatibility problem will be avoid so that I can go head on this solution.

However I’m not sure that why my latop’s Wi-Fi effect the symptom, so can you please suggest to me that how to  capture the sniffer trace and then I can provide some debug data if you need?

Thank you

0 Likes
Anonymous
Not applicable

By sniffer trace I meant wireshark trace as you showed in your previous post. Just make sure that the ICMP ping packets when the problem is occurring are shown.

0 Likes
lock attach
Attachments are accessible only for community members.
Anonymous
Not applicable

Please see the attached the Wireshark log which include the ICMP protocol, and the ICMP log generate from my laptop to WICED board. As you can see the below picture, whenever my laptop were connected with the WICED board, and then WICED STA also is happening the ping error, and also my laptop has ping error at the same time.

pastedImage_0.png

0 Likes

Have you been able to resolve this? Is it still an issue?

0 Likes
Anonymous
Not applicable

Yes, it was resolved, but the old wi-fi firmware is not stable for between laptop testing.