Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

c_ciavola
Level 1
First reply posted 5 sign-ins First question asked
Level 1

Hi everyone, I am following a firmware development project based on the WICED 4.1 SDK, I need to update the SDK to solve the famous WPA2 KRACK vulnerability.
Unfortunately, between version 4.1 and the latest 6.6.x.y versions there is no bootloader compatibility and this makes an update via OTA impossible.
So, inevitably, to fix the vulnerability I must necessarily update to version 4.1.3 as it is the last one that maintains the compatibility of the bootloaders. Now I have the problem of having to find the SDK for linux versions.
I found this topic on the support page but the links are not working: https://community.infineon.com/t5/Blogs/WICED-Studio-4-3-1-has-been-released-backport-to-address-KRA... 

Can you help me by providing me the sdk for linux versions?

Thank you

0 Likes
3 Replies
GauravS_31
Moderator
Moderator 250 sign-ins First comment on KBA 5 questions asked
Moderator

WICED is not recommended for new designs. We have moved to Modus Toolbox. Which WLAN chip and host processor is being used? Accordingly, we will suggest an appropriate SDK.

0 Likes
c_ciavola
Level 1
First reply posted 5 sign-ins First question asked
Level 1

this is a project already started in 2017, it is not a new design. The need is to solve the aforementioned vulnerability for objects already present in the field

0 Likes
Rakesh_BG
Moderator
Moderator 10 likes received 25 solutions authored 50 replies posted
Moderator

Hi @c_ciavola ,

Can you please tell which WLAN chip and host processor is being used?  

 

Thanks,

Rakesh B G

0 Likes