Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

NaFi_2915566
Level 3
Level 3
First like received First like given

Using a CYW943907AEVAL1F and Wiced Studio, I can download and start the debugger using the instructions in Re: wiced Debug , but when I try to debgu I haev problems:

  • the first line of my appication_start() is wiced_init().  If I set a breakpoint on that lien I can get there
  • If I try to step over wiced_init(), it never returns.  Instead I end up in data_abort_handler()
  • The code works fine if I run it without debug.

Any idea what may be causing this?

contents of debug window

43xxx_Wi-Fi_Debug_Windows [GDB Hardware Debugging]

last_built.elf

Thread #3 5413856 (Name: app thread, State: Ready) (Suspended : Container)

Thread #4 5349408 (Name: System Timer Thread, State: Suspended) (Suspended : Container)

Thread #5 5371032 (Name: WWD, State: Ready) (Suspended : Signal : SIGTRAP:Trace/breakpoint trap)

data_abort_handler() at exception_handlers.c:398 0x4a2e38

m2m_dma_attach() at m2m_hnddma.c:272 0x4de59a

Thread #6 5346760 (Name: worker thread, State: Waiting - Queue) (Suspended : Container)

Thread #7 5347020 (Name: worker thread, State: Waiting - Queue) (Suspended : Container)

Software/Code/43xxx_Wi-Fi/tools/ARM_GNU/Win32/bin/arm-none-eabi-gdb.exe (8.0.50.20171128)

Contents of Console

GNU gdb (GNU Tools for Arm Embedded Processors 7-2018-q2-update) 8.0.50.20171128-git

Copyright (C) 2017 Free Software Foundation, Inc.

License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>

This is free software: you are free to change and redistribute it.

There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

and "show warranty" for details.

This GDB was configured as "--host=i686-w64-mingw32 --target=arm-none-eabi".

Type "show configuration" for configuration details.

For bug reporting instructions, please see:

<http://www.gnu.org/software/gdb/bugs/>.

Find the GDB manual and other documentation resources online at:

<http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".

Type "apropos word" to search for commands related to "word".

[Switching to thread 1 (Thread -1)]

Warning: the current language does not match this frame.

[New Thread 5413856]

[New Thread 5349408]

[Switching to Thread 5413856]

Thread 3 "" hit Breakpoint 2, application_start () at apps/XXX/XXX/XXX.c:60

60    wiced_init(); /* Initialize the WICED device */

[New Thread 5371032]

[New Thread 5346760]

[New Thread 5347020]

Thread 5 "" received signal SIGTRAP, Trace/breakpoint trap.

[Switching to Thread 5371032]

0x004a2e38 in data_abort_handler () at WICED/platform/MCU/BCM4390x/../../ARM_CR4/exception_handlers.c:398

398     EXCEPTION_HANDLER_BREAKPOINT();

0 Likes
1 Solution

Providing an update for other community users:

The issue is seen on a custom board. The debug in EVAL kit with JTAG works as expected.

View solution in original post

5 Replies
PriyaM_16
Moderator
Moderator
Moderator
25 solutions authored 10 solutions authored 5 solutions authored

Do have problems in stepping in wiced_init() or is the error specific to step over? Kindly try to put another breakpoint and resume to reach that line or try to step in the wiced_init() function and step over other functions. Your debug session is starting hence there is no problem in debug configurations.

Also kindly try by adding stepi command in the startup tab of debug configurations as follows:

pastedImage_0.png

As per the debug configurations mentioned in Re: wiced Debug, ​the stepi command is not given.

The problem is definitely with wiced_init().

1. I added a few dummy lines so the start of my code looks like this now:

volatile int j1,j2,j3;

void application_start( )

{

  wiced_result_t result;

  uint32_t      flags;

  j1=1;

  j2=2;

  j3=3;

  wiced_init(); /* Initialize the WICED device */

I can break at j=1; and then step over the next two lines.  When I step over wiced_init() I get the exception I originally mentioned.

2. if I set a breakpoint on the next line after wiced_init() I never get there

3. run with no breakpoints the code always ends with the exception so it is independent of stepping.

I tried with and without "stepi", it made no difference.

As a reminder, the same code works fine without debugging, so the basic setup is correct.

0 Likes

Hello nfindikli_2915566

Are you using JTAG to debug the device?

0 Likes

EarnestB_46​  PriyaM_16

we are using the JTAG connection thru the USB connector on the CYW943907AEVAL1F.

The code runs fine with "download run: but hits an exception in wiced_init() when debugging.

I noticed that the exception handling behaves differently depending on whether DEBUG is defined.  Could it be that wiced_init() is always hitting an exception but only has an effect during debugging?

0 Likes

Providing an update for other community users:

The issue is seen on a custom board. The debug in EVAL kit with JTAG works as expected.