Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

Anonymous
Not applicable

HI all,

     I 'm using BLE functon on WICED-SDK_3.3.1.I plan to add two uuid128bit services, it appeared a strange question. If I just add one,when connect it, I can see this service with iPhone, but if add two, when connect it, I can't see any services.The attachments are my gatt_db file.

     I run example "ble_proximity_reporter", it has multiple uuid16_services, there is no this problem.

     What causes this problem? Hope someone help me a look.

0 Likes
4 Replies
MichaelF_56
Moderator
Moderator 250 sign-ins 25 comments on blog 10 comments on blog
Moderator

Moved to Wi-Fi Forums from Smart, adding Wi-Fi Apps team.

vik86 seyhan gangi jaeyoung

Team - Note this is similar to the previous question posted by the user here: 128-bit UUID service x 2

0 Likes
JaeyoungY_71
Employee
100 likes received 50 likes received 25 likes received
Employee

Hello Jixing,

We have found a fix for this issue where defining consecutive 128bit uuid services will result in an error. The solution will be included in our next release which is scheduled for the end of September. Thank you for your patience.

Thanks,

Jaeyoung

AxLi_1746341
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA
Level 7

jaeyoung wrote:

Hello Jixing,

We have found a fix for this issue where defining consecutive 128bit uuid services will result in an error. The solution will be included in our next release which is scheduled for the end of September. Thank you for your patience.

I'm wondering if you mean SDK-3.7.0-3 or not...

I didn't find this issue mention in the release note...

WICED SDK version 3.7.0-3 has been released....

0 Likes
JaeyoungY_71
Employee
100 likes received 50 likes received 25 likes received
Employee

You may download the new SDK, WICED Studio 4.0, which includes this fix from the following link.

WICED Studio 4.0 has been released....

Thanks,

Jaeyoung

0 Likes