Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

joMa_1809706
Level 4
Level 4
10 likes received First like received First like given

I have a project based on the iot-shadow example that works. When I add the -debug to a clean build of the project and set a breakpoint at the beginning of application start the breakpoint is never tripped. The console output shows:

Starting WICED v3.5.2

Platform BCM94343W_AVN initialised

demo.aws_iot.shadow-BCM94343W_AVN-debug download download_apps

also tried

demo.aws_iot.shadow-BCM94343W_AVN-debug download download_apps run

also tried clicking debug icon after load

Any help would be appreciated.

0 Likes
1 Solution
3 Replies
VikramR_26
Employee
Employee
10 sign-ins 10 comments on KBA 5 comments on KBA

Make sure you have removed all breakpoints to start fresh and run clean once before compiling the debug applicaiton

Kindly make sure you have added breakpoint at a valid line.

I tried debugging using the shadow application and noticed no issues.

Also request you to go over the debug settings in your debug configuration.

0 Likes

I said I already did that. What I want to know are the steps to setup the “debug settings in your debug configuration”.

0 Likes