cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

AnGi_4407776
New Contributor

Hello,

I am using CYW954907AEVAL1F Evaluation Kit with the correspond chipset: wl43909B0.exe

Does WICED supports 40MHz lower and upper sidebands in 5GHz?

When we tried using these commands: "wl43909B0.exe --serial X chanspec -c 38 -b 5 -w 40 -s 1

wl43909B0.exe --serial X 5g_rate -h 2 -b 40" ,

the Spectrum Analyzer shows the same plot with the same center frequency, not the upper sideband .

Best Regards,

Ana

0 Likes
1 Solution
PriyaM_16
Moderator
Moderator

Hello,

The default driver restricts to 20MHz transmission. The mimo_bw_cap will remove this restriction and allow 40MHz to be activated.

Please use this command:

wl mimo_bw_cap 1

Note: This command must be set in the down position prior to the chanspec command

View solution in original post

6 Replies
PriyaM_16
Moderator
Moderator

Lower sideband is selected through the -s option in the chanspec command.

-1 Low (or lower) sideband (applies to a 40 MHz channel bandwidth).
0 No sideband (for 20 MHz channel bandwidth).
1 High (or upper) sideband (applies to a 40 MHz channel bandwidth).

AnGi_4407776
New Contributor

The problem is that in cases  when I select the lower and upper sideband(40 Mhz channel bandwidth),on the Spectrum Analyzer I see the same plot,no changes applied.

0 Likes
AnGi_4407776
New Contributor

I already used -s for setting the sidebands but it does not work.

0 Likes
PriyaM_16
Moderator
Moderator

Can you please attach the spectrum analyzer plots for analysis?

0 Likes
AnGi_4407776
New Contributor

2.jpg

1.jpg

These are the plots that were rendered for channel 38(which is the center frequency): -  First Plot: Lower Sideband( s -1)

                                                                                            Second Plot: Upper Sideband( s 1)

In case we set channel 36 or 40 we get an error as it is a Bad Channel.

0 Likes
PriyaM_16
Moderator
Moderator

Hello,

The default driver restricts to 20MHz transmission. The mimo_bw_cap will remove this restriction and allow 40MHz to be activated.

Please use this command:

wl mimo_bw_cap 1

Note: This command must be set in the down position prior to the chanspec command

View solution in original post