Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Bluetooth for Linux Forum Discussions

OwLi_4697301
Level 1
Level 1

We have an I.MX 8mini platform and use the Murata1FX wifi chip. The OS is Android Pie.

We got the wl for android from Murata. The mfg firmware is loaded without any error.

brcm_mfg_fw_loaded-M.png

Execute "wl_arm64 -h", screen shows the help of wl.

Execute other commands like "wl_arm64 -i wlan0 ver", screen show "wl driver adapter not found".

wl_execute-m.png

Please help to solve this issue.

0 Likes
12 Replies
RaktimR_11
Moderator
Moderator
Moderator
500 likes received 250 likes received 100 likes received

What is the production firmware that you are using?

Latest release is available Cypress Linux WiFi Driver Release (FMAC) [2020-04-02]

If the wl tool works with mfg firmware, it leads me to believe that the tool is compiled correctly and there might be something else which could be causing this.

0 Likes

The firmware is mfg firmware for 1FX from Murata.

0 Likes

TiCu_2020706ScKe_1713761BiCh_3977566​ from Murata

0 Likes

We use Cypress FMAC wifi driver, I know that there is another wifi driver: Cypress DHD wifi driver.

I just wonder if the malfunction of wl is related to different wifi driver architecture.

Hi TiCu_2020706​, ScKe_1713761​, BiCh_3977566​,

Do you have any suggestion?

0 Likes

Hi,

It has been a long time, does anyone watch this issue?

0 Likes

Hi OwLi and Cypress support.

Your attached wl seems to be for DHD.

DHD and FMAC uses different wl.

I could not provide wl for brcmfmac on ARM64 Android here.

Could you create MyCase technical support?

Then ask to provide wl for Android Arm64 for brcmfmac with "NL80211=1".

1. Please visit MyCases site below.

https://www.cypress.com/mycases

2.Please select MyCases

pastedImage_1.png

3.Please select Technical Support, then you can create new MyCases.

If your account does not has Technical Support,

please report it on following link.

https://www.cypress.com/webform/website-support

pastedImage_2.png

Regards,

Matayoshi

0 Likes

Hi,

Thank you for your reply, I've created the case.

0 Likes

Hello,

I do have almost the same problem

I am running an iMX8MM EVK platform and use Murata 1MW wifi chip.

The OS is android 9 Pie and I use the official NXP android AOSP.

The 1MW is well supported since I am able to connect to WiFi through the Android OS, everything works fine ...

But I miss the wl tool for FCC test

I cannot create a Technical Support case :

We've changed the way we're providing technical support. You'll now find answers to your embedded design questions in the Cypress Developer Community 3.0. The community offers answers verified by Cypress experts, knowledge-base articles, code examples, and much more!
Technical questions? Visit CDC 3.0. Other questions? Email us at CDC3.0@cypress.com

I have tested the wl tool from your github :

GitHub - murata-wireless/cyw-fmac-utils-imx32

GitHub - murata-wireless/cyw-fmac-utils-imx64

But they cannot run under Android since they are dynamically linked :

wl: ELF 64-bit LSB executable, ARM aarch64, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-aarch64.so.1, for GNU/Linux 3.14.0, BuildID[sha1]=bf588b79f9175c49faa01f12391c6beaa60478f1, with debug_info, not stripped

I also have tried the both ones attached on the first question of this thread and get the same result :

captina:/wl dump

wl: wl driver adapter not found

Please let me know what I should do,

Best Regards,

Aurelien BOUIN

0 Likes

Can we get any support for this please ?

We just need static build of wl tools adapted to Android9 imx8mmevk board

Thanks

0 Likes

Hi Aurelien,

You can download wl for ARM64 android from following link.

Cypress Android 10 Release [2020-07-17]

[wl path]:android_v5.4.18-gamera-android-rc2_cy-imx-android-10.0-rc2_REL_PKG/cypress/utilities/arm64/wl

Thanks,

Matayoshi

Thanks Matayoshi !

That version works also under Android 9 Pie !!

Thank you very much for your support

Best regards,

Aurelien BOUIN

0 Likes
trongbang108
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

Hi support team,

I install wl on my Raspberry Pi 4, 64 bit

But it get the same issue "./wl: wl driver adapter not found"

 

pi@raspberrypi:~ $ sudo journalctl -b | grep brcmfmac
Dec 10 06:37:30 raspberrypi kernel: brcmfmac: F1 signature read @0x18000000=0x15264345
Dec 10 06:37:30 raspberrypi kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Dec 10 06:37:30 raspberrypi kernel: usbcore: registered new interface driver brcmfmac
Dec 10 06:37:30 raspberrypi kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Dec 10 06:37:30 raspberrypi kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
Dec 10 06:37:30 raspberrypi kernel: brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Mar 23 2020 02:20:01 version 7.45.206 (r725000 CY) FWID 01-febaba43
pi@raspberrypi:~ $
pi@raspberrypi:~ $

pi@raspberrypi:~ $
pi@raspberrypi:~ $ ./wl wlan0
./wl: wl driver adapter not found
pi@raspberrypi:~ $ md5sum wl
3f67a7a38f5c157d8ea22d94ef8e966a wl

0 Likes