cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

mgkiller
New Contributor II

The driver at https://www.cypress.com/documentation/software-and-drivers-archive/wifi-bt-linux-archive,  is too new for me .

How can i find one suitable for linux kernel 3.10. 

Any help is greatly appreciated

0 Likes
1 Solution
AditiB_81
Moderator
Moderator

Hi,

As per Readme of the Driver Release, the instructions are provided to build the kernel image. If you go through these instructions, you'll see the 4th point mentioned as -

#4. Enable below configs in .config
# CONFIG_ASYMMETRIC_KEY_TYPE=y
# CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE=y
# CONFIG_X509_CERTIFICATE_PARSER=y
# CONFIG_PKCS7_MESSAGE_PARSER=y

You need to enable these configs in your .config file of your kernel source. Note: These configs are not required by your kernel version but is required for backporting. So add these configs in the .config file, build the kernel image again and then go ahead with the backporting. This should resolve your above problems. Let us know if you still face issues.

Thanks

Aditi  

View solution in original post

0 Likes
4 Replies
AditiB_81
Moderator
Moderator

Hi,

Please refer to the latest FMAC Driver Release. The link is provided below-

https://community.cypress.com/t5/Wi-Fi-Bluetooth-for-Linux/Cypress-Linux-WiFi-Driver-Release-FMAC-20...

This supports Kernel 3.10. You can let us know if you face issues.

Thanks

Aditi

mgkiller
New Contributor II

Thank you for your advise,AditiB_81

I follow the guide, but face a build error about pkcs7. 

As i know,  there is not "CONFIG_PKCS7_MESSAGE_PARSER" option in my kernel v3.10, and also there is not  linux/hash_info.h  in kernel v3.10 source tree.

How do deal with this error?  can i exclude pkcs7 relative codes in this backport?

Build Logs:

mgkiller@ubuntu:~/ros/ice-aw-nm372sm/v5.4.18-backports$ make CROSS_COMPILE=/opt/arm-sam9x25-linux-gnueabi/bin/arm-sam9x25-linux-gnueabi- KLIB=$MY_KERNEL KLIB_BUILD=$MY_KERNEL modules
make[4]: 'conf' is up to date.
#
# configuration written to .config
#
Building backport-include/backport/autoconf.h ... done.
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/main.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.11.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.12.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.13.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/memneq.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.14.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.15.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.17.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.18.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-3.19.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.0.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.1.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.2.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.3.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.4.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.5.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.6.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.7.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.8.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.10.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-4.18.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-5.2.o
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-genetlink.o
/home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-genetlink.c: In function 'backport_genl_register_family':
/home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-genetlink.c:290:44: warning: passing argument 2 of 'genl_register_ops' from incompatible pointer type [-Wincompatible-pointer-types]
err = genl_register_ops(&family->family, ops + i);
^~~
In file included from /home/mgkiller/aw-nm372sm/v5.4.18-backports/backport-include/net/genetlink.h:3:0,
from /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/backport-genetlink.c:16:
include/net/genetlink.h:144:12: note: expected 'struct genl_ops *' but argument is of type 'struct backport_genl_ops *'
extern int genl_register_ops(struct genl_family *, struct genl_ops *ops);
^~~~~~~~~~~~~~~~~
CC [M] /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/verification/verify.o
In file included from /home/mgkiller/aw-nm372sm/v5.4.18-backports/include/crypto/pkcs7.h:10:0,
from /home/mgkiller/aw-nm372sm/v5.4.18-backports/compat/verification/verify.c:6:
/home/mgkiller/aw-nm372sm/v5.4.18-backports/include/crypto/backport-pkcs7.h:12:29: fatal error: linux/hash_info.h: No such file or directory
#include <linux/hash_info.h>

 

0 Likes
AditiB_81
Moderator
Moderator

Hi,

As per Readme of the Driver Release, the instructions are provided to build the kernel image. If you go through these instructions, you'll see the 4th point mentioned as -

#4. Enable below configs in .config
# CONFIG_ASYMMETRIC_KEY_TYPE=y
# CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE=y
# CONFIG_X509_CERTIFICATE_PARSER=y
# CONFIG_PKCS7_MESSAGE_PARSER=y

You need to enable these configs in your .config file of your kernel source. Note: These configs are not required by your kernel version but is required for backporting. So add these configs in the .config file, build the kernel image again and then go ahead with the backporting. This should resolve your above problems. Let us know if you still face issues.

Thanks

Aditi  

View solution in original post

0 Likes
mgkiller
New Contributor II

There is none "CONFIG_PKCS7_MESSAGE_PARSER" option in my kernel v3.10, after comment out CONFIG_PKCS7_MESSAGE_PARSER in .config and also comment out some pkcs7 related code in v5.4.18-backports,  complie sucess.

Thank you @AditiB_81