Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Bluetooth for Linux Forum Discussions

Level 1
Level 1
First reply posted First question asked Welcome!

I'm using both the 1dx and 1mw module from murata :


These use the CYW4343W and the CYW43455 respectively, and communicate over an sdio bus.

But every now and then it fails to load the firmware giving me only this error:

brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

But I have no idea what is causing this and its driving me mad, I thought it might be that it was powering on to late, so i gave it power early, but it didn't help, tried the latest firmware, didn't help.

These messages related to the module also show up in dmesg:

mmc1: SDHCI controller on 30b50000.mmc [30b50000.mmc] using ADMA
mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
mmc1: queuing unknown CIS tuple 0x80 (6 bytes)
mmc1: new ultra high speed SDR104 SDIO card at address 0001
brcmfmac: F1 signature read @0x18000000=0x15264345
brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2
brcmfmac mmc1:0001:1: Falling back to sysfs fallback for: brcm/brcmfmac43455-sdio.bin

Details of the system using it:

Linux kernel 5.10.72

Debian 11 Bullseye

imx8mm processor (aarch64)


I feel like it used to be more stable, but i can't think of anything i changed that affects it.


Can anyone help me figure out this error or point me to some documentation that can help me?

5 Replies
First question asked 5 likes given 250 sign-ins

Hi BenSpierings. 

Could you please let us know which driver are you using during the test the latest FMAC driver is available here -> could you please check with the latest driver and let us know if the issue still persists? https://community.infineon.com/t5/Wi-Fi-Bluetooth-for-Linux/Cypress-Linux-WiFi-Driver-Release-FMAC-2...

If the issue persist could you please share us the full  debug log?




Hello Vivek,

I am indeed using the latest firmware, the one that you linked.

Unfortunately what I sent just now is all the logs i have, I have seen something about setting a debug field somewhere but I'm not sure where this is. I tried putting it in the brcmfmac43430-sdio.txt and brcmfmac 43455-sdio.txt, but did not get any more verbose logs.


Thank you for your help!


Thank for the update, have you also updated the driver too?



I don't think so? I use the driver that comes with the nxp imx-linux kernel.

It looks like the updated one is for kernel 5.15.58? which I am not running.

Can you help me get the full debug log you talked about?


Hi @BenSpierings , 

The drivers are backward compatible with an older version using Linux backports project.  You could build the .ko files and load the drivers. please refer to the README file of the driver -> https://community.infineon.com/t5/Wi-Fi-Bluetooth-for-Linux/Cypress-Linux-WiFi-Driver-Release-FMAC-2...

For the debug log you can refer to the following link -> https://community.infineon.com/t5/Resource-Library/FMAC-Debugging/ta-p/246042




This widget could not be displayed.