cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Bluetooth for Linux

Anonymous
Not applicable

We have designed an IoT gateway and are having problems getting the BLE side of the LBEE5KL1DX module to work. The wifi integrated with ease, the BLE on the other hand has been giving my s/w guy fits.

Configuration:

We are integrated to a Raspberry Pi CM3 running the current stable version of Raspbian.

The WiFi is mapped to the SDIO interface, and the BLE is mapped to the serial port on the CM3.

The ON pins to enable the different radios are mapped to GPIO's on the CM3 to be turned on and off.

We reached out to Murata (LBEE5KL1DX), their response was less than favorable. They referred me here for driver support. Is there a driver or source file I can download/compile to get this thing working, thanks?

0 Likes
1 Solution
Anonymous
Not applicable

We managed to get it up and running. We found a small short under the

package when it was soldered down on the TX/RX pins.

Julius

View solution in original post

2 Replies
RaktimR_11
Moderator
Moderator

julius.miller_3572636

When you say ON pins, do you mean WL_REG_ON and BT_REG_ON ? I am not really familiar with the set-up that you are using so can't really pinpoint the root cause. Ideally, if you are correctly providing the nvram file provided by Murata, you should not see any issue in your setup as well. Please provide the error logs you are seeing in BLE side? Please confirm one more thing that whether the BLE, Wi-Fi works independently.

In our WICED Studio environment, we provide some gateway example application. You can check the same for your reference implementationWICED-Studio 6.2.1 Installer (Windows)

Anonymous
Not applicable

We managed to get it up and running. We found a small short under the

package when it was soldered down on the TX/RX pins.

Julius

View solution in original post