Announcements

Ever wondered how you could apply Infineon products in a sustainable way? Join us at OktoberTech Asia Pacific and get inspired Click here to register for FREE.

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

ArSa_3842301
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

Hi, 

I am currently working with CX3 device in order to get full-frame from CIS sensor. I have enabled several Processing Units(PU) in order to have a handshaking with sensor, and control it.

It works fine in Windows, working under UVC. But I am having problems in Ubuntu, working under V4L2.

It is a few strange, because the device is running with the same firmware, so I guess there is something wrong either uvcdscr.c or uvc.c file.

Please, could you tell me if it's common having problems between UVC and V4L2? Have I to configure the Processing Units on different way?

I have attached both uvcdscr.c and uvc.c files.

Thanks so much.

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator 5 likes given 500 solutions authored 1000 replies posted
Moderator

Hello,

Can you please check if the device is enumerated as a USB 3.0 device on the Ubuntu host? The reason for asking this is that I do not see any camera unit and processing unit controls enabled for USB 2.0 descriptors.

Regards,
Rashi

View solution in original post

0 Likes
3 Replies
Rashi_Vatsa
Moderator
Moderator 5 likes given 500 solutions authored 1000 replies posted
Moderator

Hello,

Please let me know which host application is being used for the application.

Also, let me know which camera/processing feature are you not able to use with V4L2. Please share the UART debug prints with UVC_PROP_DEBUG_ENABLE enabled when the issue is seen.

Regards,
Rashi
0 Likes
ArSa_3842301
Level 3
25 sign-ins 10 replies posted 10 questions asked
Level 3

I am using v4l2-ctl.

The most curious is that if you open the device characteristics, it doesn't show any enabled propertie. I mean, it is like if doesn't exist. So that, I cannot see anything with debug, because if the own driver doesn't set any propertie, the firmware callback function is not coming in into propertie's configuration statements.

0 Likes
Rashi_Vatsa
Moderator
Moderator 5 likes given 500 solutions authored 1000 replies posted
Moderator

Hello,

Can you please check if the device is enumerated as a USB 3.0 device on the Ubuntu host? The reason for asking this is that I do not see any camera unit and processing unit controls enabled for USB 2.0 descriptors.

Regards,
Rashi
0 Likes