Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

educhene
Level 1
Level 1
First reply posted First question asked Welcome!

Hello,

I have a software (c++) using the v1.2.3.10 version of the CyUSB3 driver (.sys). This software is statically linked with the CyAPI.lib delivered with this driver.

Now, I want to use the latest CyUSB3 driver (v1.2.3.20) with the same software. Do I need necessary to link the software with the CyAPI.lib delivered with this latest driver or I can keep my software as well (<=> no change has been done to the CyAPI.lib) ? In fact, I don't want to generate a new version of my software if not needed.

Thanks.

 

0 Likes
1 Solution
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hello,

It is better to use the latest CyAPI.lib library. It is recommended so, because it has bug fixes.

Best Regards,
AliAsgar

View solution in original post

0 Likes
3 Replies
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hello,

We recommend you to link the latest CyAPI.lib library with your software.

Best Regards,
AliAsgar

0 Likes

Of course, but if I can avoid it, it will be greatly appreciated.

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hello,

It is better to use the latest CyAPI.lib library. It is recommended so, because it has bug fixes.

Best Regards,
AliAsgar

0 Likes