Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

Philip
Level 3
Level 3
50 sign-ins 25 replies posted 25 sign-ins

Hello,

I'd like to make a non-uvc project.

I referred to the below link then make a project successfully.

https://community.cypress.com/t5/Knowledge-Base-Articles/Steps-to-Setup-up-MIPI-CSI-Camera-Solution-...

However, I cannot build it with many errors even though I didn't add my own source yet.

Philip_0-1618907614718.png

I attached my project.

Please let me know what's the problem.

Regards,

Philip

0 Likes
1 Solution
JayakrishnaT_76
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hello Philip,

I tried to develop a project with almost the same settings as yours and did not find any errors. Please find the project created at my end along with this response.

When I checked the properties of the project that was shared, I found that the Include paths and library search paths were not proper. Can you please try uninstalling the FX3 SDK once and then re-installing the latest SDK (1.3.4) from the following link:

https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

After installing the latest SDK, please check if you are still facing this issue.

Best Regards,
Jayakrishna

View solution in original post

1 Reply
JayakrishnaT_76
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hello Philip,

I tried to develop a project with almost the same settings as yours and did not find any errors. Please find the project created at my end along with this response.

When I checked the properties of the project that was shared, I found that the Include paths and library search paths were not proper. Can you please try uninstalling the FX3 SDK once and then re-installing the latest SDK (1.3.4) from the following link:

https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit

After installing the latest SDK, please check if you are still facing this issue.

Best Regards,
Jayakrishna