Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

1154533
Level 1
Level 1
First like given 5 replies posted 5 sign-ins

HI

I have installed EZ USB Suite to work with FX-3 Eval kit.

I don't see any option for OpenOCD or JLINK under "Debug Configurations". I suspect that the only option is to use OpenOCD because there is no JTAG connector on the eval kit. So, that is using the usb/serial interface. So, how can I configure the OpenOCD for that?

Thanks

0 Likes
1 Solution
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Marcos,

Could you try disabling/unchecking "Enable ARM semihosting", "Pre-run Reset" and "Connect to running target" and see if the issue persists.

Best Regards,
AliAsgar

View solution in original post

0 Likes
8 Replies
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi,

Please refer to section 3 of EzUsbSuite_UG.pdf "JTAG Debugging of firmware projects" provided with the FX3 SDK in the link "C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\doc\firmware"

Best Regards,
AliAsgar

0 Likes

Hi AliAsgar

Thanks a lot for your email and reply!

Yes, I did reinstall the SDK and now I can see the OpenOCD option on my "debug option".

And I followed the document section you mentioned. After I start the debug session, I am getting this error below (I am using USBBulkLoopAuto example):

Warn : Adapter driver 'cy7c65215' did not declare which transports it allows; assuming legacy JTAG-only
Info : only one transport option; autoselect 'jtag'
adapter_nsrst_delay: 200
jtag_ntrst_delay: 200
adapter speed: 1000 kHz
trst_and_srst srst_pulls_trst srst_gates_jtag trst_push_pull srst_open_drain connect_deassert_srst
RCLK - adaptive
adapter speed: 1000 kHz
Info : clock speed 1000 kHz
Info : JTAG tap: fx3.cpu tap/device found: 0x07926069 (mfg: 0x034, part: 0x7926, ver: 0x0)
Info : Embedded ICE version 6
Info : fx3.cpu: hardware has 2 breakpoint/watchpoint units
Info : accepting 'gdb' connection from 3333
undefined debug reason 7 - target needs reset
Error: Target not halted
Error: Target not halted
Error: Target not halted
Error: Target not halted
Error: Target not halted
Error: Target not halted
Error: Target not halted

-------------------------------

Thanks and have a wonderful holidays!

Rgrds

 

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi,

Could you please confirm if "Enable ARM semihosting" and "Pre-run reset" is unchecked in the debug configurations?

Is the EVAL kit bus powered or self powered?

Best Regards,
AliAsgar

0 Likes

Hello AliAsgar,

Thanks for your response!

I was able to find out what was wrong.

The setup for the gdb path wrong on my project. I just decided to add the full path name instead the variables that was part of the default projects. Now it worked.

D:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\ARM GCC\bin\arm-none-eabi-gdb.exe

 

I have one more question regarding JTAG for the "SlaveFifoSync" example.

I build fine and I can run the jtag debugger but it hangs. I am adding details on the word document attached.

Thanks a lot for your time.

Rgrds

Marcos

 

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Marcos,

Could you try disabling/unchecking "Enable ARM semihosting", "Pre-run Reset" and "Connect to running target" and see if the issue persists.

Best Regards,
AliAsgar

0 Likes

Thanks AliAsgar,

Just to make sure i am doing the right steps.

I loaded the image into the RAM using Control Center. After that is loaded, i can see that the enumeration changes from 'boot' to "Cypress FX3 USB StreamerExample Device".

After that, o open my "debug" configuration and then i execute the debugger.

I believe these steps are correct, right?

Ok, i did that but still getting:

"Launching SlaveFIfoSync Debug" has encountered a problem.

Error is services launch sequence.

Then, when I click on "details" i get this:

Error in services launch sequence
GDB prompt not read

Thanks again,

rgrs

marcos

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Marcos,

Can you perform the debug procedures mentioned in the EzUsbSuite_UG for OpenOCD?
These procedures should be performed when the FX3 is in bootloader mode. The debug configurations will program the code onto the RAM and then start the debug session. Please check if you are able to do it.

Best Regards,
AliAsgar

0 Likes

Hi AliAsgar

Thanks once again. Now I got it working. I don't know what i did wrong. As you suggested i followed again the instruction EzUsbSuite_UG. Also, i used absolute paths on the options for the elf files.

Anyway, thanks again for your help and time.

rgrds

Marcos

0 Likes