Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals

MatthieuMerio
Level 1
First reply posted First question asked Welcome!
Level 1

Hello, 

I made a custom board based on Lattice USB3.0 Video Bridge devkit that's use an CYUSB3014-ZXI.

When I connected it through USB cable in USB Boot mode (F11), computer detected it as peripheral : Cypress USB Bootloader.
Then I flashed firmware USBVideoBridge_bulk.img with Control Center in the EEPROM (failed) and in the flash memory through SPI (success).

But when we go in mode : SPI, On Failure, USB boot is enable(0F1), the board is not detected by the computer.

Is it necessary to flash memory with JTAG for the first power up? Or did I missed something in the datasheet of bootmode? Because I think that memory never get flashed. 

If you have any idea about what's append, please tell me.

Waiting for your return.

Matthieu 

PS: attached devkit datasheet and FX3 boot mode datasheet.

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

The attached firmware enumerates fine with FX3 SuperSpeed Explorer kit. I tried USB boot and I2C boot. Both worked at my end.

It seems that there is some problem with SPI interface on the board. For testing your SPI connection, you can load our SPI example firmware into the RAM of FX3 and try to write data to the devices and read back the same. The examples are available in the FX3 SDK in the following location

For SPI Read / Write: <FX3 SDK INSTALLATION PATH> \ 1.3\firmware\serialif_examples\cyfxusbspiregmode

If the the firmware is not found, please re install the FX3 SDK.

Regards,
Rashi

View solution in original post

0 Likes
4 Replies