Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals

firstLMM
Level 1
First question asked Welcome!
Level 1

I complete a UVC camera with FX3 CyUSB3014 with guide of AN75779, but it works well in stream mode, but it goes bad in trigger mode;

The cmos sensor works in streaming mode, and outpus raw data; the raw data is transfered to PC through FX3 on USB bus. After I set this CMOS sensor into trigger mode, and have the trigger pin in high level, no transfer continues. the firmware prints log:  "UVC: Completed 0 frames and 0 buffers". 

I check the output of cmos sensor, PCLK,FV,and LV works well. it seems that the GPIF hasn't generate event to firmware, I don't know the reseaon, because the timing is good. In the meatime, I find, when the cmos sensor is in standby mode with trigger pin low, no PCLK,FV, and LV are found.

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please refer to troubleshooting section of AN75779 

Regards,
Rashi

View solution in original post

0 Likes
2 Replies
Meghavi
Moderator
Moderator 100 replies posted 100 sign-ins 50 solutions authored
Moderator

Hi,

Kindly confirm if you are referring to the trigger based still image capture. 

Are you using AN75779 example firmware? Please mention the changes that you have made in the AN75779 firmware.

Can you please provide the timing diagram of Trigger signal, PCLK and FV, LV?

Best Regards

0 Likes
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please refer to troubleshooting section of AN75779 

Regards,
Rashi
0 Likes