Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

dilic_2635671
Level 4
Level 4

Hi,

I am working on FX3 UsbSpiDmaMode. I was able to send out control end point vendor command 0xB0 to UsbSpiDmaMode FW. And seems capture OUT/IN packet by USB protocol analyzer. See attached USBTrace screen shot.

For some reason, there is no data from IN packet. From the code, I am assuming the "FX3 SPI" should be in the IN data field.

Anything I might doing wrong? Is it the issue of CyU3PUsbSendEP0Data() or?

const uint8_t glFirmwareID[32] __attribute__ ((aligned (32))) = { 'F', 'X', '3', ' ', 'S', 'P', 'I', '\0' };

        switch (bRequest)

        {

            case CY_FX_RQT_ID_CHECK:

                CyU3PUsbSendEP0Data (8, (uint8_t *)glFirmwareID);

Thanks,

Dick

0 Likes
1 Solution
KandlaguntaR_36
Moderator
Moderator
Moderator
100 likes received 50 likes received 25 likes received

I captured the trace with Teledyne Lecroy Advisor T3.

I can see the data packet in the trace.

Also in the control center.

Attached the both here.

It looks like there is a data coming over control end point but your analyzer is missing this in decoding.

Trace.PNGControl_Req.PNG

View solution in original post

0 Likes
2 Replies
dilic_2635671
Level 4
Level 4

For some reason, the protocol analyzer is unable to show the control end point data. I am able to use control end point Read() function to get the data. Thx

0 Likes
KandlaguntaR_36
Moderator
Moderator
Moderator
100 likes received 50 likes received 25 likes received

I captured the trace with Teledyne Lecroy Advisor T3.

I can see the data packet in the trace.

Also in the control center.

Attached the both here.

It looks like there is a data coming over control end point but your analyzer is missing this in decoding.

Trace.PNGControl_Req.PNG

0 Likes