Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

LBence91
Level 4
Level 4
10 questions asked 50 sign-ins 25 replies posted

Hello,

I am currently working with the FX3 development board, and 2 different sensor (OV7670, OV426). I was able to work with the OV7670 properly, but when I have changed the descriptors for the other sensor my task manager shows 2 camera device one with proper parameters and one with invalid parameters. What can be the cause for showing 2 UVC device?

Best Regards,

Bence

multiplecams.PNG

0 Likes
1 Solution
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Bence,

Please use the attached descriptor file. The length of the VS input header descriptor has to be 0x0D + No. of formats supported = 0x0F.
I have made changes to the high speed config descriptor.
Please try this file and see if the issue still persists.
The issue was solved at our end using this descriptor file.

Note: If your device is high speed capable, 1080p @ 30fps cannot be streamed as USB 2 speeds do not meet the bandwidth requirement of 1080p@30fps.

Best Regards,
AliAsgar

View solution in original post

0 Likes
5 Replies
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Bence,

Could you let us know what changes were made to the descriptor files?

Could you share your descriptor file with us?

Best Regards,
AliAsgar

0 Likes

Hello AliAsgar,

Thank you for your response, additional information: Both of the projects made based on the AN75779 document and example code.

Best Regards,

Bence

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Bence,

Please find the attached descriptor file for ov426. I have modified the below:
1. Length of Configuration Descriptor
2. Frame and format index.
3. Added one more field inside the VS input header descriptor.

These changes are done for the superspeed configuration descriptor only.

I have also noticed that, though the YUY2 resolution is 1080p, the width, height, frame interval etc are according to the 400x400. Please make changes for the YUY2 descriptors accordingly and let me know if the issue persists.

Best Regards,
AliAsgar

0 Likes

Hello,

Our device only High speed capable so I implemented the modifications you mentioned in the HS descriptors, but still got hte same results. So I think the  duplicated enumaration caused an other part of the firmware. What you think about it?

Best Regards,

Bence

0 Likes
AliAsgar
Moderator
Moderator
Moderator
750 replies posted 50 likes received 500 replies posted

Hi Bence,

Please use the attached descriptor file. The length of the VS input header descriptor has to be 0x0D + No. of formats supported = 0x0F.
I have made changes to the high speed config descriptor.
Please try this file and see if the issue still persists.
The issue was solved at our end using this descriptor file.

Note: If your device is high speed capable, 1080p @ 30fps cannot be streamed as USB 2 speeds do not meet the bandwidth requirement of 1080p@30fps.

Best Regards,
AliAsgar

0 Likes