Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

Ankitvats
Level 1
5 sign-ins First reply posted First question asked
Level 1

Hi,

I just import the project in "EZ USB Suite" tool and try to build the project in Debug and Release mode.

But the linker script "fx3.ld" is not present in Debug/ Release Folder.

Error :: Cannot open the linker script c:\..\debug\fx3.ld: invalid argument 

Environment  variable  set : 

FX3_LIB_PATH    =  "${workspace_loc:/${ProjName}/api}"

How to resolve it??

errorFx3.JPG

error

 

 

 

environment.JPG

 environment variable set

 

 

path and symbol.JPG

 path and symbole

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please let me know where is the linker script file present for your project.

In the default FX3 projects, the path to linker script file is as in the attached snippetld_file.PNG

You can copy the linker script file to a location and add the path as above in the project settings

Regards,
Rashi

View solution in original post

0 Likes
6 Replies
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please let me know where is the linker script file present for your project.

In the default FX3 projects, the path to linker script file is as in the attached snippetld_file.PNG

You can copy the linker script file to a location and add the path as above in the project settings

Regards,
Rashi
0 Likes
Ankitvats
Level 1
5 sign-ins First reply posted First question asked
Level 1

I  copied the linker script file to a location and add the path as above in the project settings.

yes, Now I am able to build the project.

But A note is comming . Is this break the code???

Note: 256 bytes of interrupt vector code have been removed from the image.
Use the "-vectorload yes" option to retain this code.

cypress_note.JPG

0 Likes
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please confirm if the following settings are same as thiself.PNG

 

Please refer to readme.txt file in the following location (FX3 SDK Installation path\Cypress\EZ-USB FX3 SDK\1.3\util\elf2img) for more info on vector load parameter

Regards,
Rashi
0 Likes
Ankitvats
Level 1
5 sign-ins First reply posted First question asked
Level 1

But when we import the project from example in tool then Debug/ Release both have  .mk file (Makefile.mk) 

debug_mkfile.JPG

 But in My PROJECT no .mk file is generated  after fx3.ld file cpy on its location. 

no_mkfile.JPG

 Settings are

setting.JPG

 

0 Likes
Rashi_Vatsa
Moderator
Moderator 500 solutions authored 1000 replies posted 750 replies posted
Moderator

Hello,

Please let me know which steps are followed for creating the project that you are working on

Please try creating a new template project and copy the source files there and try building it.

File>New>Project>FX3 Project will create a template project for FX3

Regards,
Rashi
0 Likes