Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

Maxime_Lyn
Level 1
Level 1
First reply posted First question asked Welcome!

Hello everyone, 

We have an issue with our new PCB design. 

This is the first time we have used the FX3 for a new project and on some cards the PC does not recognise the FX3. We had three prototypes made, one works well and the other two have the problem.
On the boards with the problem, we have no crystal oscillation, DP and DN signals are at 2V and 2.7V but not moving, power supplies are good, reset is high, PMODEs are well connected for USB boot, VBUS is on the 5V of USB. Regarding the AN70707 document, we are in compliance except for the connector ground connection via a snubber.
Do you have any ideas for me to continue debugging?
If not :
- How can I know if my component is good (different date code)?
- On a new board, what are the first steps to do to start the FX3?

I attach the schematic in PJ.
With kind regards,

 

0 Likes
1 Solution
Bakal
Moderator
Moderator
Moderator
50 sign-ins 10 solutions authored 25 replies posted

Hello,

As you have mentioned above that the PC does not recognize the FX3 it could be because of the enumeration problem.

Please refer to the KBA attached below: 

https://community.infineon.com/t5/Knowledge-Base-Articles/Trouble-Shooting-Guide-for-the-FX3-FX3S-CX... 

Best Regards,
Sakshi Bakal.

View solution in original post

0 Likes
3 Replies
Bakal
Moderator
Moderator
Moderator
50 sign-ins 10 solutions authored 25 replies posted

Hello,

As you have mentioned above that the PC does not recognize the FX3 it could be because of the enumeration problem.

Please refer to the KBA attached below: 

https://community.infineon.com/t5/Knowledge-Base-Articles/Trouble-Shooting-Guide-for-the-FX3-FX3S-CX... 

Best Regards,
Sakshi Bakal.

0 Likes

Hello Bakal,

Thank you for your feedback. 

Software : With the board working, we do have the westbridge that appears. It should also appear with the other

Hardware : PMODE is set correctly, Power supply are good and the cable is certified. 

Best regards,

Maxime

0 Likes
Bakal
Moderator
Moderator
Moderator
50 sign-ins 10 solutions authored 25 replies posted

Hello Maxime,

"Software: With the board working, we do have the Westbridge that appears. It should also appear with the other" could you please elaborate on what it should also appear with?

Regards,
Sakshi Bakal

0 Likes