Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals

Not applicable



I use the U7243B USB Test App of Keysight to make a compliance test on CYUSB3014-BZXC of my board,


and the Oscilloscope cannnot get any wave form from CYUSB3014 during Device Tx test.


Since I have tried the compliance test on a usb flash drive(mass storage disk) and the result is ok,


I guess the problem is about the setting of  CYUSB3014.


What should I do to make the CYUSB3014 be ready for the compliance test?


Should I change the Firmware or do something through FPGA?


Here is the information about the CYUSB3014 on my board:


1. The firmware is SlaveFifoSync


2. The Slave FIFO Interface(GPIF II) is connected to FPGA(Altera)


Here is the step I make the Device Tx compliance test:


1.Setup the board and download the firmware to CYUSB3014


2.Connect the USB connector of board to the test fixture(of keysight), the picture is upload


3.Run the Tx test software(U7243B of keysight)


4.Disconnect the test fixture and reset the CYUSB3014(as the software requires)


5.download the firmware to CYUSB3014 and connect the test fixture and the wait for valid wave form


Then the Oscilloscope cannnot get any wave form.


By the way, I also tried to control the FPGA to send data to device,the result is same.




Looking forward to your reply.


Best regards,







2 Replies