Announcements

Industry-first USB 10Gbps device controller. Check it out now!

Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

cross mob
lock attach
Attachments are accessible only for community members.
Minwan
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

Hi

Yesterday, I uesd CX3 RDK board receive a RAW 8bit MIPI sensor Input, the project build successfully and it enumerated as CX3-UVC. But today ,I  don't change anything in this project ,I find Windows cant recognize the device anymore.

Could you please tell me is there something wrong with my project code or just some hardware issue

 

0 Likes
1 Solution
Hemanth
Moderator
Moderator
Moderator
First like given First question asked 750 replies posted

Hi Minwan,

Please right click on the project, go to 'Index' and then select 'Freshen all files'

This would remove the errors you see and then build the project.

I assume that your RDK has OV5640 on it.

Regards, 

Hemanth

View solution in original post

0 Likes
5 Replies
Hemanth
Moderator
Moderator
Moderator
First like given First question asked 750 replies posted

Hi,

Please let us know which CX3 RDK you are using?

Try out with a different PC. If it does not work, try to capture UART logs and look for errors.

Regards,

Hemanth
0 Likes
Minwan
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

Hi,

The CX3 RDK i am using is AN90369 .

I build a new project with same configuration and try it again. At the first time, the img file worked and it enumerated as CX3-UVC.  Then I want to try it again to ensure the img file still worked, so I  restart the power supply and reset the hardware, but this time, altough I use the same img file, it  doesn't enumerate as CX3-UVC. It really baffles me.

Thanks for the reply.

Regards,

Minwan

0 Likes
Hemanth
Moderator
Moderator
Moderator
First like given First question asked 750 replies posted

Hi Minwan,

Can you please program default firmware that is available in FX3 SDK and check if there is any enumeration issue?

Firmware example path: EZ-USB FX3 SDK\1.3\firmware\cx3_examples\cycx3_uvc_ov5640

Also, as I mentioned in my first post, please try with different host PCs and check UART logs for errors.

Regards,

Hemanth
0 Likes
Minwan
Level 1
Level 1
10 sign-ins 5 replies posted 5 sign-ins

Hi Hemanth,

I program default firmware, but it can't build successfully. 

Minwan_0-1624026618870.png

Regards,

Minwan

0 Likes
Hemanth
Moderator
Moderator
Moderator
First like given First question asked 750 replies posted

Hi Minwan,

Please right click on the project, go to 'Index' and then select 'Freshen all files'

This would remove the errors you see and then build the project.

I assume that your RDK has OV5640 on it.

Regards, 

Hemanth
0 Likes