Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

GaK_4661021
Level 4
Level 4
25 replies posted 10 replies posted 10 questions asked

Hi,

I am using Windows host application for the UVC extension unit from UVC Extension unit here. I have taken firmware changes reference from CX3 UVC extension unit community thread. I am using CX3 SDK-1.3 and firmware example "cycx3_uvc_ov5640" for my experiment. When I test the UVC extension unit then it always returns an error with Error code: 0x80070492. However, I am able to stream the camera on my windows host machine. I have attached detailed error logs in attachement.

Can anyone help me that is there any configuration difference in the latest SDK for the UVC extension unit? Or Am I referring wrong host application example?

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator
Moderator
5 likes given 500 solutions authored 1000 replies posted

Hello,

Please find the attached modified CX3 firmware which includes the functionality of Extension unit.

We have tested this with SDK 13.3 and 1.3.4 and it is working fine. Please test the same firmware at your end and let me know the results

Regards,

Rashi

Regards,
Rashi

View solution in original post

0 Likes
1 Reply
Rashi_Vatsa
Moderator
Moderator
Moderator
5 likes given 500 solutions authored 1000 replies posted

Hello,

Please find the attached modified CX3 firmware which includes the functionality of Extension unit.

We have tested this with SDK 13.3 and 1.3.4 and it is working fine. Please test the same firmware at your end and let me know the results

Regards,

Rashi

Regards,
Rashi
0 Likes