Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals Forum Discussions

channabasappa
Level 1
Level 1
10 sign-ins 5 sign-ins First reply posted
Hello,
 
Camera Sensor : AR1335
RAW8 ,  640*480 ,  CSI clock -160MHZ , 2-lane, 2FPS

On the Denebola development board we are successfully streaming data onto the PC without any errors. 
On our custom board -where FPGA is present in between CX3 and AR1335. This FPGA is for Muxing purpose of 4 cameras into a single MIPI .Before going to muxing with multiple cameras just we are trying single camera streaming through FPGA.

Right now we are able to stream video through FPGA on to the PC but we are getting mipi errors with improper frame size 305280 bytes.  

Received Frame size : 305280
MIPI Error :  122  0  0  0  0  0  0  0  6  

LOGS: 
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 71 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 72 Frm_Sz = 305280 B
121 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 73 Frm_Sz = 305280 B
121 0 0 0 0 0 0 0 7
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 74 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 7
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 75 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 76 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 77 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 78 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 79 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 80 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 7
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 81 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 82 Frm_Sz = 305280 B
120 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 83 Frm_Sz = 305280 B
123 0 0 0 0 0 0 0 8
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 84 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 85 Frm_Sz = 305280 B
121 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 86 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 7
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 87 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 88 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 89 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 90 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 91 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 6
Prod = 8 Cons = 8  Prtl_Sz = 10752 Frm_Cnt = 92 Frm_Sz = 305280 B
122 0 0 0 0 0 0 0 9

With Regards
channabasappa
0 Likes
1 Solution
JayakrishnaT_76
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hello,

As per my understanding, you have not changed the hardware of Denebola kit. This means that in Denebola kit, you have used the sensor OV5640 itself and not AR1335. Please correct me if my understanding is wrong.

Also, please share the following details so that we can understand the issue better:
1. Did you make use of the same configuration  settings for CX3 MIPI Receiver Block for the custom board and Denebola kit? If not, then please share the settings for us to check.

2. As per the configuration, the FPGA should output a frame size equal to 640*480 = 307200 bytes. But, it is seen that CX3 only receives 305280 bytes. Therefore, the data lost is:

Data lost = 307200 - 305280 = 1920 bytes (which is same as 1920 pixels itself as one pixel is of 1 byte)

As each line has 640 pixels, it seems like 3 lines of the frame are lost. Can you please let us know if you can probe FV, LV and PCLK testpoints on the board and share the traces with us?

Also, please refer to the following thread which mentions the Data type IDs that are supported by CX3:

https://community.cypress.com/t5/USB-Superspeed-Peripherals/CX3-Configure-IMX294/td-p/270906

If a data type ID that is not supported by CX3 is present in the packet header of a line, then it will not be sent out to the host along with the video data.

Best Regards,
Jayakrishna

View solution in original post

0 Likes
1 Reply
JayakrishnaT_76
Moderator
Moderator
Moderator
First question asked 1000 replies posted 750 replies posted

Hello,

As per my understanding, you have not changed the hardware of Denebola kit. This means that in Denebola kit, you have used the sensor OV5640 itself and not AR1335. Please correct me if my understanding is wrong.

Also, please share the following details so that we can understand the issue better:
1. Did you make use of the same configuration  settings for CX3 MIPI Receiver Block for the custom board and Denebola kit? If not, then please share the settings for us to check.

2. As per the configuration, the FPGA should output a frame size equal to 640*480 = 307200 bytes. But, it is seen that CX3 only receives 305280 bytes. Therefore, the data lost is:

Data lost = 307200 - 305280 = 1920 bytes (which is same as 1920 pixels itself as one pixel is of 1 byte)

As each line has 640 pixels, it seems like 3 lines of the frame are lost. Can you please let us know if you can probe FV, LV and PCLK testpoints on the board and share the traces with us?

Also, please refer to the following thread which mentions the Data type IDs that are supported by CX3:

https://community.cypress.com/t5/USB-Superspeed-Peripherals/CX3-Configure-IMX294/td-p/270906

If a data type ID that is not supported by CX3 is present in the packet header of a line, then it will not be sent out to the host along with the video data.

Best Regards,
Jayakrishna
0 Likes