Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB low-full-high speed peripherals

james
Level 1
First reply posted First question asked Welcome!
Level 1

Our product based on cy7c68013a.

Most of them are Normally operating well. But some product did not be recognized about 2~3 times out of 10.

Power source, reset timing, i2c clk, data lines were good. However,there was someting very strange about i2c data voltage abnormal.

There was no pull up, or data transaction, but voltage level about 1.4v with pull down sometimes.(our voltage level 3.3v)

I haven't seen this symptom. Would you tell me how to debug this symptom? Wold you tell me how to solve this problem?

0 Likes
1 Solution
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Can you please confirm if you are using the latest version of cyusb3.sys driver present in the FX3 SDK?

https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit 

Regards,

Mallika

View solution in original post

0 Likes
7 Replies
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hello,

Please refer to the document and ensure that the schematic is according to the KBA: https://community.cypress.com/t5/Knowledge-Base-Articles/Schematic-Review-Checklist-for-EZ-USB-FX2LP... 

Kindly provide your schematic for review.

Best Regards,

Mallika

0 Likes
james
Level 1
First reply posted First question asked Welcome!
Level 1

Thanks, but all harware designs are followed cypress hardware design guide.

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hi,

I understand but kindly provide your schematics for a quick review once.

Also, please elaborate on the issue which you are facing.

Regards,

Mallika

0 Likes
james
Level 1
First reply posted First question asked Welcome!
Level 1

james_0-1614232159451.png

here, It is schematics for cypress circuit. I think it doesn't cause a problem.

And Issue is that USB Device Not recognize happened sometimes (about 2~3 times out of 10).

When this device recognized normally, all operation is perfect. but Unknown USB Device status happened sometimes...

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hello,

>> Can you please let me know if this behaviour is being displayed by 1 board or all the boards?

>> Is this issue seen with all the PCs?

>>  As you mentioned that about 2-3 times the device does not gets recognized. From here, how are you bringing it back to working mode?

Regards,

Mallika

 

0 Likes
james
Level 1
First reply posted First question asked Welcome!
Level 1

1.  I just displayed cypress circuit. I know that USB device recognition is a part of cypress work.

2.  Yes.. 

3. When the device dos not gets recognized, I can not do anything. So, I just power off and on and then it recognize well again. It is Very strange symptom.. 

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Can you please confirm if you are using the latest version of cyusb3.sys driver present in the FX3 SDK?

https://www.cypress.com/documentation/software-and-drivers/ez-usb-fx3-software-development-kit 

Regards,

Mallika

0 Likes