Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB low-full-high speed peripherals Forum Discussions

SuSh_1535366
Level 5
Level 5
50 questions asked 50 replies posted 50 sign-ins

Hello,

I am using CYUSB232 RDK to check the operation of CY7C65213-32LTXI.

After connecting the device to the USB, its TXD line is High.

However, once the port is opened / closed by software (ex. TeraTerm Pro), the TXD line becomes indeterminate(Probably Hi-Z state).

Therefore, incorrect data will be sent to the receiving side.

Is there a way to avoid this situation?

Thanks,

Shimamura

0 Likes
1 Solution

Hi Shimamura-san,

Sorry for the delay in my response.

USB bus will enter idle mode if the COM port is closed and USB host can selective suspend the device after idle timeout.

This selective suspend will put the USB-UART device to deep sleep with Tx pin held Hi-Z mode.

Tx pin not in Hi-Z will violate USB specification VBUS current consumption limits.

Best regards,

Hirotaka Takayama

View solution in original post

4 Replies
HirotakaT_91
Moderator
Moderator
Moderator
50 likes received 25 likes received 10 likes received

Hello,

I have not seen this phenomenon.

Could you please explain your settings?

Does it happen even if you use Default Configuration setting?

Best regards,

Hirotaka Takayama

0 Likes
SuSh_1535366
Level 5
Level 5
50 questions asked 50 replies posted 50 sign-ins

Hello Takayama-san,

Yes, I am using the default setting.

And the serial port configuration is:

baud rate: 19200

data bit: 8

stop bit: 1

parity: none

hand shake: hardware

Regards,

Shimamura

0 Likes

Hi Shimamura-san,

Sorry for the delay in my response.

USB bus will enter idle mode if the COM port is closed and USB host can selective suspend the device after idle timeout.

This selective suspend will put the USB-UART device to deep sleep with Tx pin held Hi-Z mode.

Tx pin not in Hi-Z will violate USB specification VBUS current consumption limits.

Best regards,

Hirotaka Takayama

Hello Takayama-san,

Thank you for your reply.

I confirmed that TxD remains High when disabling selective suspend.

Regards,

Shimamura

0 Likes