Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB low-full-high speed peripherals Forum Discussions

miga_1697941
Level 1
Level 1

     Hi,chip is CY7C68013A,The configuration is shown in the figure.

QQ截图20190816114137.jpg

     when the other USB ports plug and unplug the U disk, this  device’s EP6 endpoint will be deadlock,but other endpoints are functioning normally.Then just Reset Pipe EP6 on Control Center and the device will work normally.

    Can you tell me what’s wrong? Thanks.

0 Likes
1 Solution

Hello,

The firmware shared works fine.

I replaced the VID and PID in the firmware your shared with cypress VID and PID as I did not have your driver.

Please let me know if you are finding the issue with cyusb3 driver as well.

Best Regards,

Yatheesh

View solution in original post

0 Likes
3 Replies
YatheeshD_36
Moderator
Moderator
Moderator
750 replies posted 500 replies posted 250 solutions authored

Hello,

Can you please let me know which PC and host controller is being used and are facing the same issue on a different PCs?

Can you share the firmware project with us.

Best Regards,

Yatheesh

0 Likes

Hi Yatheesh,

    I am using an older controller(Pentium E5500).But there is no such problem on the i7 CPU. Computers similar to mine also have this problem. Recently, I revised the firmware with reference to the routine to solve this problem. Can you help me see if this is feasible?

0 Likes

Hello,

The firmware shared works fine.

I replaced the VID and PID in the firmware your shared with cypress VID and PID as I did not have your driver.

Please let me know if you are finding the issue with cyusb3 driver as well.

Best Regards,

Yatheesh

0 Likes