Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB low-full-high speed peripherals Forum Discussions

Wanjie
Level 1
First reply posted First question asked Welcome!
Level 1

We used this CY7C65630-56LFXA chip on our equipment. On each unit, we have two chips to control 6 SD cards. While on Win7 OS, we have no problems to harvest the data on all 6 SD cards. After switching to Win10 OS, we can only see one SD card each time. We searched online and tried many solutions, but none of them helped us. Is this a driver issue? Any suggestion how to solve this problem?

 

One engineer said we can replace this chip with a new one, which has the same pins and works on Win10 and Win11. We don't need to modify the design and other parts. Do you have a recommended chip? 

 

Thank you.  

 

0 Likes
7 Replies
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hi,

Even HX2LP works on Windows 10. Can you please share screenshots from the device manager?

Regards,

Mallika

0 Likes
Wanjie
Level 1
First reply posted First question asked Welcome!
Level 1

Hello Mallika,

Thank you so much for your reply. Here is a screen shoot. You see there is only one SD card named "Z81_CH6".  When plugged on WIN 10, there are two "Generic USB Hub" under Device Manger,  which should be the two chips. With identical configuration, when plugged on Win 7, we can see all 6 SD cards. 

We verified that if the computers are purchased with Win 10 and we downgrade them to Win 7, we can see all 6 SD cards. If the computers are purchased with Win7 and we upgraded them to Win10, they work fine for us. We bought a Dell laptop with Win10 in 2017 when most of computers were still Win7, which was about $400. It has three USB ports. One USB port worked fine and we can see all 6 SD cards under this port. However, the other two ports didn't work and we can only see one SD card using them. 

We tried many solutions listed online. None of them helped. One of engineers suggested we can replace this chip with a newer pin-to-pin chip, which is an easy solution. Maybe that 's what we should do next. 

Wanjie_0-1657940914164.png

Best Regards,

Wanjie

 

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hi,

Can you please once try using another DS device? OR Can you use the SD cards alone without the hub controller and test if it enumerates on the PC?

Regards,

Mallika

0 Likes
Wanjie
Level 1
First reply posted First question asked Welcome!
Level 1

Hello Mallika,

Thanks again. We did develop a Raspberry PI device, whose solo function is to harvest data from our system. We can pull out all 6 SD cards, and plug them on PC, which works fine, but it doesn't look good for a product. We still want to find a solution to fix the issue on Win 10. 

Do you have a pin-to-pin chip to replace this CY7C65630-56LFXA, and working on Win 10 and Win 11? 

Best regards,

Wanjie

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hi,

Without the hub controller, do the SD cards enumerate on the PC?

0 Likes
Wanjie
Level 1
First reply posted First question asked Welcome!
Level 1

Hello Mallika,

We never tried that. We can pull all 6 SD cards out and plug them all on Win10. This works fine. Under current design, the hub controller is the bridge between the PC and SD cards. I cannot test your suggestion under current design. 

Thanks. 

Best regards,

Wanjie 

0 Likes
MallikaK_22
Moderator
Moderator 250 solutions authored 500 replies posted 250 replies posted
Moderator

Hi,

As I had mentioned before, CY7C65630 does work with Win 10. We have not seen such issues before with the HX2LP chip on Windows 10.

- Can you please confirm if you are using the same cable for Win 7 and Win 10.

- Will it be possible to share the USB logs between the hub and PC for Win 10 using a hardware analyzer such as  Lecroy or Wireshark?

- In the first post you mentioned that the configuration worked on a USB port in Win 10 but not with other ports. Is that correct?

- Is the issue seen on 1 host PC or multiple host PCs?

Regards,

Mallika

 

0 Likes