cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

HuYa_4249091
Contributor

Hi, I've enabled the Exposure Time(Absolute) in USB Camera Terminal Descriptor & corresponding FW code, and it worked.

I tried to add Auto Exposure Mode. Therefore I added it in USB Camera Terminal Descriptor & corresponding FW code.
Refer UVC spec:
Auto exposure spec.JPG

Because I only enabled the Exposure Time(Absolute) ability before, I thought I should use "D3: Aperture Priority Mode".
Thus, I set auto_exposure_mode variable = 0x08(0b00001000) in UVCHandleCameraTerminalRqts().
my FW.JPG

The ability was available. And the default status enable Auto Exposure. That's what I need.
VirtualDub.jpg

If I disabled the check button , the FW received the  CY_FX_USB_UVC_GET_CUR_REQ & CY_FX_USB_UVC_SET_CUR_REQ requests.

However, if I enable the check button, the FW only received the CY_FX_USB_UVC_GET_CUR_REQ request, but don’t receive CY_FX_USB_UVC_SET_CUR_REQ request.
I need the CY_FX_USB_UVC_SET_CUR_REQ request to enable my auto exposure mechanism.
Is there any incorrect in my setting for case CY_FX_UVC_CT_AE_MODE_CONTROL(second image)?

Any help will be highly appreciated!

0 Likes
1 Solution
Hemanth
Moderator
Moderator

Hi,

What you did looks correct.

After you un-check the box, can you print the auto_exposure_mode variable and verify if it is indicating manual mode?

Also try with another host software too.

Regards,

Hemanth

View solution in original post

2 Replies
Hemanth
Moderator
Moderator

Hi,

What you did looks correct.

After you un-check the box, can you print the auto_exposure_mode variable and verify if it is indicating manual mode?

Also try with another host software too.

Regards,

Hemanth

View solution in original post

HuYa_4249091
Contributor

Dear Hemanth:

Thanks for your reply! I found the problem is that I set the auto_exposure_mode variable as local variable in UVCHandleCameraTerminalRqts() originally.
After I change the variable as global variable, the behavior is correct as I want.

Thank you!

0 Likes